Compiling error on Mint 18 Spring 103

Compiling error on Mint 18 Spring 103

Discuss everything related to running Spring on your chosen distribution of Linux.

Moderator: Moderators

Post Reply
Gambix
Posts: 2
Joined: 23 Jul 2017, 14:55

Compiling error on Mint 18 Spring 103

Post by Gambix » 23 Jul 2017, 15:04

Hi to all,
I've downloaded spring 103 official tarball and i want to compile it in my mint. I've added the missing LibBoost package but it seem I have an unresolvable problem with Java. Please can you help me ?. This is the output of CMake :


fabien@fabien-TERRA-MOBILE-1749S ~/Téléchargements/Spring/spring $ export JAVA_HOME=/usr/lib/jvm/java-8-openjdk-amd64/
fabien@fabien-TERRA-MOBILE-1749S ~/Téléchargements/Spring/spring $ cmake .
-- gcc 5.4.0 detected
-- Checking to see if CXX compiler accepts flag -fvisibility=hidden
-- Checking to see if CXX compiler accepts flag -fvisibility=hidden - yes
-- Checking to see if CXX compiler accepts flag -std=gnu++11
-- Checking to see if CXX compiler accepts flag -std=gnu++11 - yes
compiler doesn't support: -fcheck-pointer-bounds
-- Building Spring on 64bit environment
-- Targetting 64bit
-- Boost version: 1.58.0
-- Found the following Boost libraries:
-- thread
-- regex
-- program_options
-- system
-- chrono
-- signals
-- filesystem
-- date_time
-- atomic
-- Boost version: 1.58.0
-- Found the following Boost libraries:
-- timer
-- chrono
-- system
-- Could NOT find DevIL (missing: IL_IL_HEADER IL_INCLUDE_DIR IL_IL_LIBRARY IL_LIBRARIES)
-- Found ld.gold
-- Compiling with C++11
-- Checking to see if CXX compiler accepts flag -fdiagnostics-color=always
-- Checking to see if CXX compiler accepts flag -fdiagnostics-color=always - yes
-- using mtune=generic
-- Building Assimp with flags -fuse-ld=gold -std=gnu++11 -fdiagnostics-color=always -mtune=generic -msse -mfpmath=sse -mno-sse2 -mno-sse3 -mno-ssse3 -mno-sse4.1 -mno-sse4.2 -mno-sse4 -mno-sse4a -mno-avx -mno-fma -mno-fma4 -mno-xop -mno-lwp -mno-avx2 -frounding-math -mieee-fp -pipe -fno-strict-aliasing -fvisibility=hidden -fvisibility-inlines-hidden -pthread
-- Found AI Wrapper: CUtils (sources only wrapper)
CMake Error at /usr/share/cmake-3.5/Modules/FindJava.cmake:135 (message):
Error executing java -version
Call Stack (most recent call first):
AI/Interfaces/Java/CMakeLists.txt:245 (FIND_PACKAGE)


-- Configuring incomplete, errors occurred!
See also "/home/fabien/Téléchargements/Spring/spring/CMakeFiles/CMakeOutput.log".
See also "/home/fabien/Téléchargements/Spring/spring/CMakeFiles/CMakeError.log".



Thank you
0 x

gajop
Moderator
Posts: 3023
Joined: 05 Aug 2009, 20:42

Re: Compiling error on Mint 18 Spring 103

Post by gajop » 23 Jul 2017, 15:50

I recommend you try the 104 RC: https://springrts.com/wiki/Download_Testing

I didn't think it was necessary, but install Java perhaps? Or disable compiling Java AIs.
0 x

User avatar
ThinkSome
Posts: 292
Joined: 14 Jun 2015, 13:36

Re: Compiling error on Mint 18 Spring 103

Post by ThinkSome » 24 Jul 2017, 10:28

> - Could NOT find DevIL (missing: IL_IL_HEADER IL_INCLUDE_DIR IL_IL_LIBRARY IL_LIBRARIES)

also take a look at ./configure --help
0 x

hokomoko
Spring Developer
Posts: 585
Joined: 02 Jun 2014, 00:46

Re: Compiling error on Mint 18 Spring 103

Post by hokomoko » 24 Jul 2017, 10:39

also to disable java ais use cmake -DAI_TYPES=NATIVE
0 x

abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

Re: Compiling error on Mint 18 Spring 103

Post by abma » 31 Jul 2017, 17:19

ThinkSome wrote:also take a look at ./configure --help
there is no "configure" executable in the spring source repository. spring uses cmake for generating "make" files.
-- Could NOT find DevIL (missing: IL_IL_HEADER IL_INCLUDE_DIR IL_IL_LIBRARY IL_LIBRARIES)
https://springrts.com/wiki/Building_Spr ... nux#Ubuntu

-> very likely you forgot to "apt-get install libdevil-dev"

whats the output of /usr/lib/jvm/java-8-openjdk-amd64/bin/java -version ?
0 x

Gambix
Posts: 2
Joined: 23 Jul 2017, 14:55

Re: Compiling error on Mint 18 Spring 103

Post by Gambix » 11 Sep 2017, 08:17

Got it working ... Thanks to all of you
0 x

Post Reply

Return to “Linux”

cron