inactive window minimization issue

inactive window minimization issue

Discuss everything related to running Spring on your chosen distribution of Linux.

Moderator: Moderators

Post Reply
[last]Butters
Posts: 15
Joined: 10 Aug 2014, 20:32

inactive window minimization issue

Post by [last]Butters » 12 Mar 2017, 12:49

Spring window is minimized when other window is taking focus. This is particularly annoying for 2 monitor setup.
Is there any option to turn this of? or is this an issue with linux / X windows?
when minimized it is also receiving less of CPU time lagging out and causing CPU spikes when taking back focus.

ubuntu 16, xfce
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14603
Joined: 17 Nov 2005, 02:43

Re: inactive window minimization issue

Post by Forboding Angel » 12 Mar 2017, 13:07

Use windowed fullscreen?
0 x

[last]Butters
Posts: 15
Joined: 10 Aug 2014, 20:32

Re: inactive window minimization issue

Post by [last]Butters » 12 Mar 2017, 17:19

what is windowed fullscreen?
it starts fullscreen. also i have keyboard bind to make it fullscreen and back. I have [v] Run full-screen in settings.
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14603
Joined: 17 Nov 2005, 02:43

Re: inactive window minimization issue

Post by Forboding Angel » 13 Mar 2017, 01:14

Windows fullscreen is a borderless window that is set to the dimensions of the screen. If you're playing BA or Evo, in the options menu there is a toggle for windowed and fullscreen.
0 x

[last]Butters
Posts: 15
Joined: 10 Aug 2014, 20:32

Re: inactive window minimization issue

Post by [last]Butters » 26 Mar 2017, 10:18

So, what I am asking for is persistent borderless fullscreen mode, even in case when Spring window loses focus, or became inactive window. This makes point in dual screen (2 monitors) setup.
My environment: Linux, X Window (I am using Ubuntu 16, xfce / Xubuntu).

Is there config option for such behavior?
1 x

[last]Butters
Posts: 15
Joined: 10 Aug 2014, 20:32

Re: inactive window minimization issue

Post by [last]Butters » 05 Nov 2017, 09:54

SDL default behavior for "desktop friendly fullscreen" window is minimize when focus lost. This is often unwanted behavior in case you have two or more monitors (or virtual desktops). To fix it environment variable SDL_VIDEO_MINIMIZE_ON_FOCUS_LOSS should be set to 0. One way to do it to append to ~/.profile file following line:
export SDL_VIDEO_MINIMIZE_ON_FOCUS_LOSS=0

-----------
sources:
https://www.reddit.com/r/linux_gaming/c ... ized_when/
https://github.com/i3/i3/issues/1516
https://www.libsdl.org/

Regards to Butters. He so good. such smart. much respect. wow comunity. fagget fairies. "fixin" balance =)
HF
1 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: inactive window minimization issue

Post by albator » 05 Nov 2017, 23:05

Alternatively you can always do without fullscreen, and keybind moving to keyboard, fps style...
Here are option to tune your window on multiple screen :

Fullscreen = 0
WindowPosX = 1080
WindowPosY = 505
WindowState = 0
XResolutionWindowed = 2558
YResolutionWindowed = 1367
0 x

Kloot
Spring Developer
Posts: 1865
Joined: 08 Oct 2006, 16:58

Re: inactive window minimization issue

Post by Kloot » 06 Nov 2017, 13:03

He so good. such smart.
Smart, but not quite smart enough to know that instead of exporting an env-var for Spring he could just do this...
springsettings.cfg wrote: MinimizeOnFocusLoss=0
... and leave the minimizing behavior of other SDL2 windows unaffected.
1 x

dansan
Server Owner & Developer
Posts: 1192
Joined: 29 May 2010, 23:40

Re: inactive window minimization issue

Post by dansan » 06 Nov 2017, 15:55

Oh great!
That was so annoying, but I always thought it's just me an a weird WM :)
*happy*
0 x

[last]Butters
Posts: 15
Joined: 10 Aug 2014, 20:32

Re: inactive window minimization issue

Post by [last]Butters » 11 Nov 2017, 18:17

Kloot =) why you don't just congratulate my selfhelp, and inform us that there is spring option for it =) don't blame my smart by your knowledge.
i was kinda sarcastic on about myself. and was lucky to find after half a year a solution to issue nobody cares about to help.
0 x

Post Reply

Return to “Linux”