[SOLVED] Problem compiling spring on Slackware Current 64bit

[SOLVED] Problem compiling spring on Slackware Current 64bit

Discuss everything related to running Spring on your chosen distribution of Linux.

Moderator: Moderators

Post Reply
Buumi
Posts: 4
Joined: 07 Jun 2012, 17:35

[SOLVED] Problem compiling spring on Slackware Current 64bit

Post by Buumi »

I tried to compile Spring on slackware current 64bit but I'm having problems. I installed AlienBOB's OpenJDK and Devil, icu4c, OpenAL, p7zip and it's dependency wxPython from Slackbuilds.org before I tried to build it. I also tried to download the source of spring again.


Here's build log.. Did I miss some packages? It says could not find Maven and
-- Python unitsync wrapper will NOT be created
-- because pygccxml was not found
http://pastebin.com/TgQqbmV5

Has somebody got it working?

Edit: One interesting thing is that the same setup compiles testing version fine. So that version works.. http://springrts.com/wiki/Download_Testing
Last edited by Buumi on 08 Jun 2012, 20:32, edited 1 time in total.
User avatar
hoijui
Former Engine Dev
Posts: 4344
Joined: 22 Sep 2007, 09:51

Re: Problem compiling spring on Slackware Current 64bit

Post by hoijui »

maven not found and the pythoninterface thong are not the reason for the build to fail.
In file included from /home/jori/Downloads/spring_88.0/rts/lib/assimp/code/TriangulateProcess.cpp:66:0:
/home/jori/Downloads/spring_88.0/rts/lib/assimp/code/PolyTools.h: In instantiation of ”bool Assimp::OnLeftSideOfLine2D(const T&, const T&, const T&) [with T = aiVector2D]”:
/home/jori/Downloads/spring_88.0/rts/lib/assimp/code/TriangulateProcess.cpp:342:46: required from here
/home/jori/Downloads/spring_88.0/rts/lib/assimp/code/PolyTools.h:56:31: virhe: ”GetArea2D” was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
/home/jori/Downloads/spring_88.0/rts/lib/assimp/code/PolyTools.h:90:15: huom: ”template<class T> double Assimp::GetArea2D(const T&, const T&, const T&)” declared here, later in the translation unit
?

varoitus? warning
huom? error?

... pro-tip: finnish compiler messages no good idea
Buumi
Posts: 4
Joined: 07 Jun 2012, 17:35

Re: Problem compiling spring on Slackware Current 64bit

Post by Buumi »

varoitus = warning and huom = note.

Anyway, I think it's indeed good to get rid of finnish messages so here's new build log with locale set to en_US.utf8.

http://pastebin.com/zjrufv4E

With the same computer and system spring testing version compiled fine when I tried that on yesterday.
dansan
Server Owner & Developer
Posts: 1203
Joined: 29 May 2010, 23:40

Re: Problem compiling spring on Slackware Current 64bit

Post by dansan »

Buumi wrote:slackware current
gcc-4.7 problem?
Buumi
Posts: 4
Joined: 07 Jun 2012, 17:35

Re: Problem compiling spring on Slackware Current 64bit

Post by Buumi »

dansan wrote:
Buumi wrote:slackware current
gcc-4.7 problem?
Slackware current indeed has gcc-4.7

[ installed ] - gcc-4.7.0-x86_64-1
[ installed ] - gcc-g++-4.7.0-x86_64-1
[ installed ] - gcc-gfortran-4.7.0-x86_64-1
[ installed ] - gcc-gnat-4.7.0-x86_64-1
[ installed ] - gcc-go-4.7.0-x86_64-1
[ installed ] - gcc-java-4.7.0-x86_64-1
[ installed ] - gcc-objc-4.7.0-x86_64-1
[ installed ] - gccmakedep-1.0.2-noarch-2

I tried to slackpkg reinstall gcc but still same problem. Is there problem with spring 88 and gcc-4.7 or is the problem somewhere else on my system? Has somebody got it to run on slackware-current?

Edit1: I made some research and found that page https://launchpad.net/ubuntu/+source/sp ... +dfsg1-1.1.
It says * Work around build failure with GCC 4.7, build with -fpermissive. So I made export CXX="g++ -fpermissive" and it builds.
I still need to check if it is synced or did that break something else. I'll report then.

Edit2: It actually works now. Thanks for hoijui and dansan for giving a hint to where to look at!
Post Reply

Return to “Linux”

cron