Ubuntu package is 0.78.2?

Ubuntu package is 0.78.2?

Discuss everything related to running Spring on your chosen distribution of Linux.

Moderator: Moderators

Post Reply
User avatar
PauloMorfeo
Posts: 2004
Joined: 15 Dec 2004, 20:53

Ubuntu package is 0.78.2?

Post by PauloMorfeo » 25 Jul 2009, 02:35

I just installed Spring in my Ubuntu 8.04 Long Term Support like it is explained in
http://springrts.com/wiki/Ubuntu_install
But now the lobby says that i have 0.78.2 which is not the current version, which is 0.79.1.
Something i should do to correct or should i just wait for the package to be updated?

Also, "Tools"->"Check for new version" reports that my version is 0.0.1 while the version is 0.5. Same thing. Should i do something?

About mods and maps. Should i download them manually or throw the Lobby? I read in
http://springrts.com/wiki/Ubuntu_install
that the lobby can download for me...

(my Win XP went berserk, Lsas.exe just died and it won't even boot. I'm not likely to re-install it *again*, and *again* ruin the Ubuntu boot, in the near future)

[edit]
Super mega excelent superb job in general that people have done with Spring since i last hanged around.
0 x

User avatar
clericvash
Posts: 1394
Joined: 05 Oct 2004, 01:05

Re: Ubuntu package is 0.78.2?

Post by clericvash » 25 Jul 2009, 15:57

All you need to do for the mods and maps is download them and place them in the mods and maps folder in your spring home directory, easy peasy.
0 x

User avatar
PauloMorfeo
Posts: 2004
Joined: 15 Dec 2004, 20:53

Re: Ubuntu package is 0.78.2?

Post by PauloMorfeo » 27 Jul 2009, 01:04

Not so easy, because i would have to find the place where they are suposed to be.

But, in fact, it was even easier than what you explained (if i knew those folder paths). I just downloaded 2 mods, they are .sdz, double-clicked on them and it opened me a Spring window asking me if i want to install those mods. Couldn't be easier...
0 x

YokoZar
Posts: 883
Joined: 15 Jul 2007, 22:02

Re: Ubuntu package is 0.78.2?

Post by YokoZar » 27 Jul 2009, 01:25

The 8.04 packages are out of date. 8.10 and 9.04 are up to date though.
0 x

User avatar
PauloMorfeo
Posts: 2004
Joined: 15 Dec 2004, 20:53

Re: Ubuntu package is 0.78.2?

Post by PauloMorfeo » 27 Jul 2009, 21:43

If it takes more than some work maintaining the packages, i say you should only maintain packages for the most current version on Ubuntu, in this case 9.04.

If someone is up to maintaining 2 packages, i recomend maintaining the most current "development" version (9.04) and the most current version of Ubuntu *LTS*, in this case 8.04.

It is often that people decide to stick with the LTS versions which are quite more stable and serious than the "development" versions of Ubuntu, while the people who follow the "development" versions usually upgrade soon after a new release is released, making maintaining versions like 8.10 less usefull.

This is just an opinion, as i have no statistical data to back it up. Maybe you could actually share some statistics on the average downloads distributed by each version?
0 x

imbaczek
Posts: 3629
Joined: 22 Aug 2006, 16:19

Re: Ubuntu package is 0.78.2?

Post by imbaczek » 28 Jul 2009, 18:21

the problem with current ubuntu LTS is it's simply FUBAR and you need considerable backport updates for spring to behave sanely (openal, i'm looking at you - unless 8.04 has the fixed version and i got confused.)
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Re: Ubuntu package is 0.78.2?

Post by hoijui » 02 Aug 2009, 10:46

well.. ubuntu LTS is not foobar. it is definatly the most stable for ATI users in general of 8.04, 8.10 and 9.04.
As this is important for spring, i agree it would be better to support 8.04 then 8.10. Though yeah... boost and OpenAL have to be backportet, so i can understand that this is not done.
Next release of spring will work wiht boost 1.34 again, so only OpenAL had to be backported then.
0 x

YokoZar
Posts: 883
Joined: 15 Jul 2007, 22:02

Re: Ubuntu package is 0.78.2?

Post by YokoZar » 03 Aug 2009, 15:35

The 8.10 packages are basically identical to the 9.04 ones it wasn't much effort at all to support them

8.04 requires backporting a bunch of libraries
0 x

Gys
Posts: 8
Joined: 21 May 2009, 23:34

Re: Ubuntu package is 0.78.2?

Post by Gys » 06 Aug 2009, 23:00

Hello
I have exactly the same problem.
I have an ATI X1400 graphics card that require Ubuntu 8.04 to run. I tried to update Spring with the Jaunty deposit (in the sources.list) :

Code: Select all

jaunty main deb http://ppa.launchpad.net/spring/ppa/ubuntu
But it is a failure.
If anyone knows how to run Spring on Ubuntu 8.04, tell me plz!
(I don't know what is "backporting")
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Re: Ubuntu package is 0.78.2?

Post by hoijui » 07 Aug 2009, 10:44

backporting means, you get the source code of a recent release (eg of boost), and compile it for your old version of ubuntu.
for example, ubuntu 8.04 has boost version 1.34. but for spring you need 1.35+. so you go to the boost homepage, get the sources for 1.39, compile and install them.
if you want proper sound, you need to do the same with OpenAL (and probably some dependencies, if it has any).
Then you can get the release branch of spring by git, and compile it.

... its not very user friendly, but doable ;-)
0 x

Gys
Posts: 8
Joined: 21 May 2009, 23:34

Re: Ubuntu package is 0.78.2?

Post by Gys » 08 Aug 2009, 21:29

ok tyvm hoijui, I'll try it.
0 x

YokoZar
Posts: 883
Joined: 15 Jul 2007, 22:02

Re: Ubuntu package is 0.78.2?

Post by YokoZar » 19 Aug 2009, 08:47

Gys wrote:ok tyvm hoijui, I'll try it.
it's less work to update Ubuntu 8.04 to 8.10 itself. Seriously.
0 x

User avatar
JohannesH
Posts: 1793
Joined: 07 Apr 2009, 12:43

Re: Ubuntu package is 0.78.2?

Post by JohannesH » 19 Aug 2009, 13:19

YokoZar wrote:
Gys wrote:ok tyvm hoijui, I'll try it.
it's less work to update Ubuntu 8.04 to 8.10 itself. Seriously.
Gys wrote:I have an ATI X1400 graphics card that require Ubuntu 8.04 to run.
0 x

Post Reply

Return to “Linux”