Engine Testing - 102.0-RC1

Engine Testing - 102.0-RC1

Discuss Spring news, such as fresh releases and press coverage, here.
hokomoko
Spring Developer
Posts: 587
Joined: 02 Jun 2014, 00:46

Engine Testing - 102.0-RC1

Post by hokomoko »

Due to several major performance issues in 101.0, a new version is planned soon-ish so here's the first release candidate.
Your test games will help us make sure such issues won't slip into 102.0.

Without further ado:

Download
See the download page for how to get it.

Bugs
If you find a bugs, please report to Mantis.
Please attach infolog.txt as file, if you crash!

Happy testing! :-)
0 x

Super Mario
Posts: 814
Joined: 21 Oct 2008, 02:54

Re: Engine Testing - 102.0-RC1

Post by Super Mario »

https://springrts.com/mantis/view.php?i ... 2#bugnotes
Come on abma, you didn't fix the bug.
0 x

User avatar
Silentwings
Moderator
Posts: 3613
Joined: 25 Oct 2008, 00:23

Re: Engine Testing - 102.0-RC1

Post by Silentwings »

you didn't fix the bug
Please stick to mantis when its already used (also note that #5137 is not currently included in the roadmap for 102).
0 x

gajop
Moderator
Posts: 3023
Joined: 05 Aug 2009, 20:42

Re: Engine Testing - 102.0-RC1

Post by gajop »

Hey, any plans for a 102 release? For LD (April 15th), we probably want to use current develop for engine due to some of its major optimizations wrt custom object materials(shaders). Wouldn't mind a stable (relatively bug-free) version :)
0 x

hokomoko
Spring Developer
Posts: 587
Joined: 02 Jun 2014, 00:46

Re: Engine Testing - 102.0-RC1

Post by hokomoko »

No mass tests were done yet...
0 x

gajop
Moderator
Posts: 3023
Joined: 05 Aug 2009, 20:42

Re: Engine Testing - 102.0-RC1

Post by gajop »

OK, can we get a new RC out by the 8th of April then? We'll do mini (dev) tests at least :P
0 x

Google_Frog
Moderator
Posts: 2444
Joined: 12 Oct 2007, 09:24

Re: Engine Testing - 102.0-RC1

Post by Google_Frog »

I don't expect an engine to work without mass testing. Currently my mass testing is held up by compatibility issues.
0 x

Google_Frog
Moderator
Posts: 2444
Joined: 12 Oct 2007, 09:24

Re: Engine Testing - 102.0-RC1

Post by Google_Frog »

I fixed my blocking compatibility issues and found a noticable drop in performance. Apparently hokomoko is investigating.

Benchmarks: https://docs.google.com/spreadsheets/d/ ... sp=sharing
0 x

hokomoko
Spring Developer
Posts: 587
Joined: 02 Jun 2014, 00:46

Re: Engine Testing - 102.0-RC1

Post by hokomoko »

can you benchmark again with latest engine?
0 x

User avatar
PepeAmpere
Posts: 586
Joined: 03 Jun 2010, 01:28

Re: Engine Testing - 102.0-RC1

Post by PepeAmpere »

btw, 102 RC1 crash for OSX

other experience is overall good, we run it on our servers and we will provide some observations

is possible to make RC2 from some later repo version pls with another attempt for working OSX build?
0 x

Google_Frog
Moderator
Posts: 2444
Joined: 12 Oct 2007, 09:24

Re: Engine Testing - 102.0-RC1

Post by Google_Frog »

I have another benchmark. https://docs.google.com/spreadsheets/d/ ... sp=sharing

It looks like dev engine has much better FPS. I will try to find the reason for this because the change is suspiciously large.
0 x

hokomoko
Spring Developer
Posts: 587
Joined: 02 Jun 2014, 00:46

Re: Engine Testing - 102.0-RC1

Post by hokomoko »

The FPS boost is mostly caused by not drawing decals for icons and other drawing improvements. A smaller factor is that piece matrices now aren't calculated unless they are needed (by script/weapons/viewing). Both of these affect the benchmark performance greatly since it is fully zoomed out.

I believe there also exists a small perf issue which when solved may boost FPS even further.
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14616
Joined: 17 Nov 2005, 02:43

Re: Engine Testing - 102.0-RC1

Post by Forboding Angel »

For me in some fairly extensive testing, rc1 has been steady as a rock.
0 x

User avatar
PepeAmpere
Posts: 586
Joined: 03 Jun 2010, 01:28

Re: Engine Testing - 102.0-RC1

Post by PepeAmpere »

Based on viewtopic.php?f=12&t=33843 i suppose that legacy loading and unloading should work and its completely broken.
  • In 101.0 only NOTA airbuses had issues with unload,
  • in 102.0 RC1 all airtransports are unable to load and unload.
Is possible it was not discovered by anyone? Because I do not see it on mantis.
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14616
Joined: 17 Nov 2005, 02:43

Re: Engine Testing - 102.0-RC1

Post by Forboding Angel »

Oh shit you're right... normal atlas style transports are broken in evo. Good catch!
0 x

User avatar
Silentwings
Moderator
Posts: 3613
Joined: 25 Oct 2008, 00:23

Re: Engine Testing - 102.0-RC1

Post by Silentwings »

Is possible it was not discovered by anyone?
For example, it was not discovered by me because they work in BAR.

Although I did get the impression that loading/unloading is not as smooth as it should (and in 100.0 used to) be; the transport sometimes wiggles around a bit trying to get close in to its target unit, and also when its trying to place the transportee back on the ground.
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14616
Joined: 17 Nov 2005, 02:43

Re: Engine Testing - 102.0-RC1

Post by Forboding Angel »

I'm guessing that it's broken for everyone using bos/cob, but working for lus.
0 x

User avatar
Silentwings
Moderator
Posts: 3613
Joined: 25 Oct 2008, 00:23

Re: Engine Testing - 102.0-RC1

Post by Silentwings »

I don't think so.
0 x

User avatar
PepeAmpere
Posts: 586
Joined: 03 Jun 2010, 01:28

Re: Engine Testing - 102.0-RC1

Post by PepeAmpere »

PepeAmpere wrote:... Because I do not see it on mantis.
Reported https://springrts.com/mantis/view.php?id=5218
0 x

User avatar
Jools
XTA Developer
Posts: 2805
Joined: 23 Feb 2009, 16:29

Re: Engine Testing - 102.0-RC1

Post by Jools »

Which one is the RC1? I tested with 101.0.1-298-g38c1688 develop and legacy transports work there with xta.
0 x

Post Reply

Return to “News”

cron