Spring 94.0/1 - Page 5

Spring 94.0/1

Discuss Spring news, such as fresh releases and press coverage, here.
zerver
Spring Developer
Posts: 1358
Joined: 16 Dec 2006, 20:59

Re: Spring 94.0/1

Post by zerver »

Google_Frog wrote:Do I have to make a snap decision whether to like something and then stick to it while ignoring future evidence?
No. The customer is always right :wink:

Imo 95.0 is a better idea since 94.1 is somewhat playable.
0 x

User avatar
PepeAmpere
Posts: 587
Joined: 03 Jun 2010, 01:28

Re: Spring 94.0/1

Post by PepeAmpere »

danil_kalina wrote:Spring 94.1, Mac OS X: rendering artifacts

Square Bordes

http://pbrd.co/ZG6RL3
maybe the widget doing the rectangle net sourounding the map
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: Spring 94.0/1

Post by albator »

Hey, I just post for a thanks to all spring dev since Spring got much better, and even if some bug made the game most CPU expensive (but that might be related to bugs anyway).
Also, as a ffa player, I REALLY enjoy the MT version and it kinda made me renew the interest for the game. I hope from now and then MT will be the default version so everyone can enjoy it.
0 x

User avatar
PepeAmpere
Posts: 587
Joined: 03 Jun 2010, 01:28

Re: Spring 94.0/1

Post by PepeAmpere »

Graphic drivers problem on my friends problematic computer in office. I traveled there and i did some run -> crash. This report coresponds to this old one (report for engine 93.2)
PepeAmpere wrote:i have only one small experience with this, but not much relevant. My friends playing spring usually from office were unable to use 93.2 windows portable versions on their office machines (=> crash), but with 91.0 portable there was no problem.
Today check
card: GeForce 210
drivers version: 314.22
last tested stable spring OK: 91.0
crash in: 93.1 +

rest of report in archive
0 x

User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7024
Joined: 16 Nov 2004, 13:08

Re: Spring 94.0/1

Post by zwzsg »

94.1 crash me when loading : http://pastebin.com/p5w0h3Uq
Last edited by zwzsg on 26 Apr 2013, 10:43, edited 1 time in total.
0 x

User avatar
PepeAmpere
Posts: 587
Joined: 03 Jun 2010, 01:28

Re: Spring 94.0/1

Post by PepeAmpere »

Two things:
  • tanks reverse is broken - they sometimes freeze ("wait order") and dont move and dont react on any order for few seconds, its worse at tanks with smaller ACCeleration (fat ones - Reaper, Goliath,...), maybe some pathing priority, dont know
  • maxReverseVelocity unitDef is for nothing in current Spring, doesnt work (=> so i marked it in wiki). Im not angry this is not working, cause no game has not this tag, but when i was testing first bug, i tried to add this parameter of unit and no value helps it.
0 x

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: Spring 94.0/1

Post by knorke »

zwzsg: acuelly is 94.1?

PepeAmpere: could not reproduce, reverse driving still works:
Tested with SpringTutorialGame, put maxReverseVelocity=6.0 into simplehover and was able to drive backwards. Dudes in my game still moonwalk as well.
iirc in classic pathfinder (or whats it called) units can not go backwards, maybe its that? If its imo worth its own thread/report.
0 x

User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7024
Joined: 16 Nov 2004, 13:08

Re: Spring 94.0/1

Post by zwzsg »

Yes, 94.1, sorry, corrected. Current version I mean.
0 x

abma
Spring Developer
Posts: 3600
Joined: 01 Jun 2009, 00:08

Re: Spring 94.0/1

Post by abma »

@zwzsg:
C:\A\Jeux\RTS\Spring\Run\spring-94.1\spring.exe 0x00000000 ??:0
C:\A\Jeux\RTS\Spring\Run\spring-94.1\spring.exe 0x00660B3F build/default/../../rts/Rendering/Shaders/GLSLCopyState.cpp:387

afaik setting 3DTrees = 0 should "fix" this crash / in 95 it should be fixed, too. so please test if current development version works. but not sure, its a crash because a shader fails to compile it seems, so disabling shaders could fix it, too. (AdvUnitShading / AdvMapShading)
0 x

User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7024
Joined: 16 Nov 2004, 13:08

Re: Spring 94.0/1

Post by zwzsg »

Thanks. Might take me a few days before I test again though.
0 x

User avatar
PepeAmpere
Posts: 587
Joined: 03 Jun 2010, 01:28

Re: Spring 94.0/1

Post by PepeAmpere »

knorke wrote:PepeAmpere: could not reproduce, reverse driving still works:Tested with SpringTutorialGame, put maxReverseVelocity=6.0 into simplehover and was able to drive backwards. Dudes in my game still moonwalk as well.
iirc in classic pathfinder (or whats it called) units can not go backwards, maybe its that? If its imo worth its own thread/report.
In NOTA there was reverse working for a long time (3 years back), in Spring 91.0 there was no problem, in Spring 94.1 sometimes happends, that you send 10 tanks backwards, 7 move and 3 stay at place. In case of single unit it happends, too.

When I started with debug, i thought, its only because NOTA is noob old game with old definition files, so i added maxReverseVelocity tag with some values (tested 3-4 values) and nothing was changed.

Later I added maxReverseVelocity=0 and units were still able to reverse :), but with same problems - some units sometimes freeze under uncancable Wait order.

Today i started to suspect heatmapping, i try to play with this.
0 x

Kloot
Spring Developer
Posts: 1867
Joined: 08 Oct 2006, 16:58

Re: Spring 94.0/1

Post by Kloot »

0 x

User avatar
PepeAmpere
Posts: 587
Joined: 03 Jun 2010, 01:28

Re: Spring 94.0/1

Post by PepeAmpere »

Thx kloot, you are right, that is the reason for freezing units. I forgot we have gadget from old times for it.

I tested Spring driven reverse and its not usable, yet, for our game. Is possible to set somewhere the distance, for which the reverese is used (currently its used only for really really small distances, it looks theres some pathing caluclation that makes the decision).

200-300 is still valuable command distance for reverse for all tanks (from gamplay view) but currently spring driven reverse is used max for distance around 50.
0 x

User avatar
PepeAmpere
Posts: 587
Joined: 03 Jun 2010, 01:28

Re: Spring 94.0/1

Post by PepeAmpere »

PepeAmpere wrote:Thx kloot, you are right, that is the reason for freezing units. I forgot we have gadget from old times for it.
  • Btw - i tested the gadget and i think the problem is not in it. Seems that velocity data provided by spring via Spring.GetUnitVelocity(unitID) are not updated every frame. Seems current spring update data about unit speed less frequently.
  • Hm Spring.GetUnitVelocity(unitID) is ok, theres some small numbers in conditions issue :)
  • Ok - solved, the problem was, the current Spring no longer likes this lua notation of numbers in condition:

Code: Select all

if (vx >= .05 or vx <= -.05) then
now wants this

Code: Select all

if (vx >= 0.05 or vx <= -0.05) then
So the problem was our gadget, but there was changed Spring lua parsing or something or work with small numbers.

The maxReverseVelocity tag works, but is unusable imo from reasons i wrote above.

Thx Kloot for targeting me on right place :-)
0 x

TotalAnnihilation
Posts: 19
Joined: 18 Mar 2012, 16:48

Re: Spring 94.0/1

Post by TotalAnnihilation »

Which Games, AI and Maps work with Spring94.1?
0 x

User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7024
Joined: 16 Nov 2004, 13:08

Re: Spring 94.0/1

Post by zwzsg »

abma wrote:@zwzsg:
C:\A\Jeux\RTS\Spring\Run\spring-94.1\spring.exe 0x00000000 ??:0
C:\A\Jeux\RTS\Spring\Run\spring-94.1\spring.exe 0x00660B3F build/default/../../rts/Rendering/Shaders/GLSLCopyState.cpp:387
afaik setting 3DTrees = 0 should "fix" this crash / in 95 it should be fixed, too. so please test if current development version works. but not sure, its a crash because a shader fails to compile it seems, so disabling shaders could fix it, too. (AdvUnitShading / AdvMapShading)
Neither work.

I tried with
- Spring 94.1.1-376-gef79e98 develop (OMP)
- 3DTrees = 0

I still have a crash, still on /rts/Rendering/Shaders/GLSLCopyState.cpp 387

Edit: But with --safemode it works!
0 x

Google_Frog
Moderator
Posts: 2448
Joined: 12 Oct 2007, 09:24

Re: Spring 94.0/1

Post by Google_Frog »

We're back to using 91.0. Spring 94.1 is painfully slow or unplayable for a decent portion of the ZK playerbase. These people did not have issues when using 91.0.
0 x

User avatar
marciolino
Posts: 268
Joined: 06 Sep 2010, 22:59

Re: Spring 94.0/1

Post by marciolino »

Hi, I keep constantly crashing after sometime ingame, it can happens at 5min or at 40min.

I am using spring94.1.app bunddle for mac and notalobby.
Here is my infolog.
http://pastebin.com/XJLerEHf
0 x

zerver
Spring Developer
Posts: 1358
Joined: 16 Dec 2006, 20:59

Re: Spring 94.0/1

Post by zerver »

Google_Frog wrote:Spring 94.1 is painfully slow or unplayable for a decent portion of the ZK playerbase.
99% chance you are suffering from the pathfinder issue, as mentioned in this thread and many others:
http://springrts.com/phpbb/viewtopic.ph ... 07#p541037
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14637
Joined: 17 Nov 2005, 02:43

Re: Spring 94.0/1

Post by Forboding Angel »

Well gee, that's what happens when someone (I.E. You) shit out a spring version without adequate testing against the wishes of EVERYONE else.
0 x

Post Reply

Return to “News”