Spring 93.0 - Page 2

Spring 93.0

Discuss Spring news, such as fresh releases and press coverage, here.
Senna
Posts: 315
Joined: 17 Mar 2009, 00:20

Re: Spring 93.0

Post by Senna »

installed and not working, crash not even run when double click spring.exe, disabled 3d trees etc and still not working, it says spring has encountered a problem and need to be closed
0 x

Senna
Posts: 315
Joined: 17 Mar 2009, 00:20

Re: Spring 93.0

Post by Senna »

it may the installer be wrong? cuz ive used windows installer
0 x

abma
Spring Developer
Posts: 3566
Joined: 01 Jun 2009, 00:08

Re: Spring 93.0

Post by abma »

@Senna:

infolog.txt please?!
0 x

Senna
Posts: 315
Joined: 17 Mar 2009, 00:20

Re: Spring 93.0

Post by Senna »

there is no infolog, because it wont launch
0 x

User avatar
SpliFF
Posts: 1224
Joined: 28 Jul 2008, 06:51

Re: Spring 93.0

Post by SpliFF »

0 x

User avatar
jamerlan
Balanced Annihilation Developer
Posts: 683
Joined: 20 Oct 2009, 13:04

Re: Spring 93.0

Post by jamerlan »

I reported a bug http://springrts.com/mantis/view.php?id=3536 no sounds when selecting factory in BA

Please correct me if it's not a bug.

P.S. Thanks to all developers!
0 x

User avatar
jamerlan
Balanced Annihilation Developer
Posts: 683
Joined: 20 Oct 2009, 13:04

Re: Spring 93.0

Post by jamerlan »

One more issue reported: 2 units queued with only one click
http://springrts.com/mantis/view.php?id=3537
Sorry, wanted to report one more issue, but was mine fault. All OK
0 x

User avatar
jamerlan
Balanced Annihilation Developer
Posts: 683
Joined: 20 Oct 2009, 13:04

Re: Spring 93.0

Post by jamerlan »

Played vs AI. Game ended only when all units died. Not when commander died. (maybe that's correct behavior and needed options were not passed to mod). I tested without lobby. Just using spring executable
0 x

User avatar
Jools
XTA Developer
Posts: 2805
Joined: 23 Feb 2009, 16:29

Re: Spring 93.0

Post by Jools »

jamerlan wrote:Played vs AI. Game ended only when all units died. Not when commander died. (maybe that's correct behavior and needed options were not passed to mod).
That is *not* the correct behaviour, but it is becoming more and more popular nevertheless. Nowadays the engine doesn't deal with this issue, it is dealt withing the mod. I think there's an option somewhere where you can choose.
0 x

User avatar
jamerlan
Balanced Annihilation Developer
Posts: 683
Joined: 20 Oct 2009, 13:04

Re: Spring 93.0

Post by jamerlan »

New issue reported: Cursor placed incorrectly. Try to zoom out and aim beamer's bottom (in BA 7.72)

http://springrts.com/mantis/view.php?id=3538
0 x

User avatar
Jools
XTA Developer
Posts: 2805
Joined: 23 Feb 2009, 16:29

Re: Spring 93.0

Post by Jools »

Issue with spring 93: when attacking water with ranged units in line mode, they will not shoot at target, but instead to to drive towards it. See screenshot.

http://springrts.com/mantis/view.php?id=3539
0 x

abma
Spring Developer
Posts: 3566
Joined: 01 Jun 2009, 00:08

Re: Spring 93.0

Post by abma »

@Senna:

without more info we are unable to help i guess...
0 x

User avatar
Jools
XTA Developer
Posts: 2805
Joined: 23 Feb 2009, 16:29

Re: Spring 93.0

Post by Jools »

Kurious wrote:Don't you realize that when you let your lobby connect to the Internet you already give it all the necessary permissions to do that? Unless you've looked at the source yourself, the lobby could already be downloading things and you wouldn't know.
You would know that it uses network when it is not expected to do so and then you can chuck it. But again, this discussion is not relevant to spring 93.0.
0 x

User avatar
Jools
XTA Developer
Posts: 2805
Joined: 23 Feb 2009, 16:29

Re: Spring 93.0

Post by Jools »

Kurious wrote: When you're logged in, you would expect the lobby to use the network constantly.
No.
0 x

SevenArm23
Posts: 47
Joined: 08 Mar 2013, 16:07

Re: Spring 93.0

Post by SevenArm23 »

I can now save and load? ( In singleplayer games )
0 x

Buumi
Posts: 4
Joined: 07 Jun 2012, 17:35

Re: Spring 93.0

Post by Buumi »

93.0 64bit static linux build seems to (?) again depend upon glibc => 2.14 as when I try to run it in Debian wheezy it reports

Code: Select all

spring_93.0/spring: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by spring_93.0/spring)
spring_93.0/spring: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by spring_93.0/spring)
spring_93.0/spring: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.15' not found (required by spring_93.0/spring)
Edit: Thanks jk for the info, I'll just build it then.
Last edited by Buumi on 09 Mar 2013, 14:52, edited 1 time in total.
0 x

User avatar
Jonny5isalivetm
Posts: 169
Joined: 04 Jul 2006, 02:43

Re: Spring 93.0

Post by Jonny5isalivetm »

Hello

Decided to do some testing..

Pathing with BA 7.72 seems bad, units getting stuck behind the small craters on comet.

Only had immobile builder enabled lua wise.

RAI

Got a crash about 15min mark, just locked up using MT

http://pastebin.com/7yvLmuap
0 x

User avatar
jK
Spring Developer
Posts: 2299
Joined: 28 Jun 2007, 07:30

Re: Spring 93.0

Post by jK »

glibc cannot be downgraded on the 64bit buildbot, it would come a reinstall of the whole OS near.
So use 32bit one then.
0 x

Senna
Posts: 315
Joined: 17 Mar 2009, 00:20

Re: Spring 93.0

Post by Senna »

abma wrote:@Senna:

without more info we are unable to help i guess...
i think it dont run, due to memory limits 1 gb ram 667 mhz,
3500+ amd athlon single 2,2 ghz
0 x

User avatar
jK
Spring Developer
Posts: 2299
Joined: 28 Jun 2007, 07:30

Re: Spring 93.0

Post by jK »

try smaller map then
0 x

Post Reply

Return to “News”