Release: Spring 84.0! The DragonSlayer! - Page 2

Release: Spring 84.0! The DragonSlayer!

Discuss Spring news, such as fresh releases and press coverage, here.
Google_Frog
Moderator
Posts: 2445
Joined: 12 Oct 2007, 09:24

Re: Release: Spring 84.0! The DragonSlayer!

Post by Google_Frog »

0 x

Pako
Posts: 174
Joined: 12 Jul 2009, 18:57

Re: Release: Spring 84.0! The DragonSlayer!

Post by Pako »

Google_Frog wrote:Map texture bug again.
Have you tried turning it off and on again?
If that doesn't help press L ingame or try removing spring config file.
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Re: Release: Spring 84.0! The DragonSlayer!

Post by hoijui »

i remember having had the same thing (i think on my intel card), and kloot or jk told me to turn something off in springsettings, which fixed it. it might have been shadows, but could be something else.
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Re: Release: Spring 84.0! The DragonSlayer!

Post by hoijui »

found the mantis report:
http://springrts.com/mantis/view.php?id=2677

-> try turning off advanced map shading
0 x

Google_Frog
Moderator
Posts: 2445
Joined: 12 Oct 2007, 09:24

Re: Release: Spring 84.0! The DragonSlayer!

Post by Google_Frog »

How do you turn off advanced map shading? There is no option in springsetttings.exe and spring handles configs poorly. I think springsettings.cfg should be created if not found and any missing setting should be filled in with the default value.

Anyway if something causes a problem for a significant portion of user it should be off by default regardless of who's fault the problem is.

Some people are also experiencing unexplained 100% CPU from the start of the game.
0 x

massive
Posts: 29
Joined: 29 Nov 2010, 12:29

Re: Release: Spring 84.0! The DragonSlayer!

Post by massive »

Google_Frog wrote:How do you turn off advanced map shading? There is no option in springsetttings.exe and spring handles configs poorly. I think springsettings.cfg should be created if not found and any missing setting should be filled in with the default value.
Type in game "/advmapshading"
0 x

varikonniemi
Posts: 447
Joined: 03 Jul 2011, 11:54

Re: Release: Spring 84.0! The DragonSlayer!

Post by varikonniemi »

Hmm, seems to be some problems with the packaging for ubuntu?

Here is a code snippet of what i tried and what happened:

Code: Select all

q@varikonniemi-desktop:~$ sudo apt-get install spring
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 spring : Depends: spring-common (= 84.0~11.10~ppa1) but it is not going to be installed
          Recommends: springlobby but it is not going to be installed or
                      spring-lobby
E: Unable to correct problems, you have held broken packages.
q@varikonniemi-desktop:~$ 

Code: Select all

q@varikonniemi-desktop:~$ sudo aptitude install spring
The following NEW packages will be installed:
  spring{b} 
The following packages are RECOMMENDED but will NOT be installed:
  springlobby 
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 18.0 MB of archives. After unpacking 46.7 MB will be used.
The following packages have unmet dependencies:
  spring: Depends: spring-common (= 84.0~11.10~ppa1) but it is not going to be installed.
The following actions will resolve these dependencies:

       Remove the following packages:                                    
1)       flashplugin-downloader                                          
2)       flashplugin-installer                                           
3)       ia32-libs-multiarch                                             
4)       libacl1                                                         
5)       libasound2                                                      
6)       libasound2-plugins                                              
7)       libasyncns0                                                     
8)       libatk1.0-0                                                     
9)       libattr1                                                        
10)      libaudio2                                                       
11)      libavahi-client3                                                
12)      libavahi-common3                                                
13)      libc6                                                           
14)      libcairo2                                                       
15)      libcomerr2                                                      
16)      libcups2                                                        
17)      libcupsimage2                                                   
18)      libcurl3                                                        
19)      libdatrie1                                                      
20)      libdb5.1                                                        
21)      libdbus-1-3                                                     
22)      libdrm-intel1                                                   
23)      libdrm-nouveau1a                                                
24)      libdrm-radeon1                                                  
25)      libdrm2                                                         
26)      libexpat1                                                       
27)      libffi6                                                         
28)      libflac8                                                        
29)      libfontconfig1                                                  
30)      libfreetype6                                                    
31)      libgcc1                                                         
32)      libgcrypt11                                                     
33)      libgdbm3                                                        
34)      libgdk-pixbuf2.0-0                                              
35)      libgl1-mesa-dri                                                 
36)      libgl1-mesa-glx                                                 
37)      libglapi-mesa                                                   
38)      libglib2.0-0                                                    
39)      libgnutls26                                                     
40)      libgpg-error0                                                   
41)      libgssapi-krb5-2                                                
42)      libgtk2.0-0                                                     
43)      libice6                                                         
44)      libidn11                                                        
45)      libjack-jackd2-0                                                
46)      libjasper1                                                      
47)      libjpeg62                                                       
48)      libjson0                                                        
49)      libk5crypto3                                                    
50)      libkeyutils1                                                    
51)      libkrb5-3                                                       
52)      libkrb5support0                                                 
53)      liblcms1                                                        
54)      libldap-2.4-2                                                   
55)      libllvm2.9                                                      
56)      libmng1                                                         
57)      libnspr4                                                        
58)      libnspr4-0d                                                     
59)      libnss3                                                         
60)      libnss3-1d                                                      
61)      libogg0                                                         
62)      libpango1.0-0                                                   
63)      libpciaccess0                                                   
64)      libpcre3                                                        
65)      libpixman-1-0                                                   
66)      libpng12-0                                                      
67)      libpulse0                                                       
68)      libqt4-dbus                                                     
69)      libqt4-declarative                                              
70)      libqt4-designer                                                 
71)      libqt4-network                                                  
72)      libqt4-opengl                                                   
73)      libqt4-qt3support                                               
74)      libqt4-script                                                   
75)      libqt4-scripttools                                              
76)      libqt4-sql                                                      
77)      libqt4-svg                                                      
78)      libqt4-test                                                     
79)      libqt4-xml                                                      
80)      libqt4-xmlpatterns                                              
81)      libqtcore4                                                      
82)      libqtgui4                                                       
83)      librtmp0                                                        
84)      libsamplerate0                                                  
85)      libsasl2-2                                                      
86)      libsasl2-modules                                                
87)      libselinux1                                                     
88)      libsm6                                                          
89)      libsndfile1                                                     
90)      libspeexdsp1                                                    
91)      libsqlite3-0                                                    
92)      libssl1.0.0                                                     
93)      libstdc++6                                                      
94)      libtasn1-3                                                      
95)      libthai0                                                        
96)      libtiff4                                                        
97)      libuuid1                                                        
98)      libvorbis0a                                                     
99)      libvorbisenc2                                                   
100)     libwrap0                                                        
101)     libx11-6                                                        
102)     libxau6                                                         
103)     libxcb-render0                                                  
104)     libxcb-shm0                                                     
105)     libxcb1                                                         
106)     libxcomposite1                                                  
107)     libxcursor1                                                     
108)     libxdamage1                                                     
109)     libxdmcp6                                                       
110)     libxext6                                                        
111)     libxfixes3                                                      
112)     libxft2                                                         
113)     libxi6                                                          
114)     libxinerama1                                                    
115)     libxrandr2                                                      
116)     libxrender1                                                     
117)     libxss1                                                         
118)     libxt6                                                          
119)     libxxf86vm1                                                     
120)     nspluginviewer                                                  
121)     nspluginwrapper                                                 
122)     zlib1g                                                          

       Keep the following packages at their current version:             
123)     spring [Not Installed]                                          

       Leave the following dependencies unresolved:                      
124)     ia32-libs recommends ia32-libs-multiarch                        
125)     ubuntu-restricted-addons recommends flashplugin-installer       
126)     flashplugin-downloader recommends libasound2-plugins (>= 1.0.16)


Accept this solution? [Y/n/q/?]
Edit: removing spring-common separately from spring and rebooting my computer fixed it and now it installed normally.
Last edited by varikonniemi on 23 Nov 2011, 16:05, edited 1 time in total.
0 x

abma
Spring Developer
Posts: 3575
Joined: 01 Jun 2009, 00:08

Re: Release: Spring 84.0! The DragonSlayer!

Post by abma »

@Google_Frog

i guess these 100% cpu come from this bug: http://springrts.com/mantis/view.php?id=2368

Possible workaround is to disable sound effects: http://springrts.com/wiki/FAQ:trouble#d ... nd_effects
0 x

User avatar
det
Moderator
Posts: 737
Joined: 26 Nov 2005, 11:22

Re: Release: Spring 84.0! The DragonSlayer!

Post by det »

varikonniemi wrote:Hmm, seems to be some problems with the packaging for ubuntu?
Launchpad built and published the spring package for amd64 a couple hours before it built and published the spring-common package. Rebooting didn't fix anything, time did :)
0 x

User avatar
nrv
Posts: 24
Joined: 05 Aug 2010, 10:06

Re: Release: Spring 84.0! The DragonSlayer!

Post by nrv »

It seems pathing has some troubles with huge amount of units (small test on a speed metal). Did you change things on this part ?
0 x

User avatar
Enjinn
Posts: 1
Joined: 14 Oct 2010, 15:19

Re: Release: Spring 84.0! The DragonSlayer!

Post by Enjinn »

det wrote:
varikonniemi wrote:Hmm, seems to be some problems with the packaging for ubuntu?
Launchpad built and published the spring package for amd64 a couple hours before it built and published the spring-common package. Rebooting didn't fix anything, time did :)
Appreciate you're talking about amd64 but I can't seem to get springlobby installed alongside spring (not spring-engine) under 32-bit Lucid. Anyone else managed this and if so what could I possibly be doing wrong?

Code: Select all

apt-get install spring 
worked fine but then I had no lobby so tried to install this too:

Code: Select all

sudo apt-get install springlobby
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
  springlobby: Depends: spring-engine but it is not going to be installed
E: Broken packages
Using the standard ppa:

Code: Select all

ppa:spring/ppa
Previously had all this running as sweet as a nut under 10,04 using the spring-engine and springlobby packages. Can no longer use spring-engine as it's not been maintained beyond 82.7 by the look of things.

Help?
0 x

User avatar
det
Moderator
Posts: 737
Joined: 26 Nov 2005, 11:22

Re: Release: Spring 84.0! The DragonSlayer!

Post by det »

edit: I think I see the problem, the springlobby package in lucid has the wrong depend

I uploaded a package that I hope fixes the depend on lucid, but it probably wont go live for 6 hours.
0 x

abma
Spring Developer
Posts: 3575
Joined: 01 Jun 2009, 00:08

Re: Release: Spring 84.0! The DragonSlayer!

Post by abma »

in spring-common some ai files are missing.

these files are copied when run "make install", so i don't know what went wrong there...

Note:
If reconnect doesn't work, please remove "ReconnectTimeout = 0" from .springrc on the server-side, see http://springrts.com/mantis/view.php?id=2757
0 x

User avatar
det
Moderator
Posts: 737
Joined: 26 Nov 2005, 11:22

Re: Release: Spring 84.0! The DragonSlayer!

Post by det »

Fixed missing Shard AI files, should be available in ppa by tomorrow.
0 x

User avatar
zoggop
Posts: 289
Joined: 07 Sep 2010, 18:47

Re: Release: Spring 84.0! The DragonSlayer!

Post by zoggop »

Hooray!

...the OS X .app crashes with every mod I've tried (BA, NOTA, Spring 1944 1.53). This seems particularly strange, as 0.84 was mostly a bugfix of 0.83, and the 0.83 OS X release worked fine for me.

Code: Select all

[f=0000000] Loading Radar Icons
[f=0000000] Loading GameData Definitions
[f=0000000] Loading all definitions:  0.388000
[f=0000000] Game::LoadDefs (GameData): 438 ms
[f=0000000] Loading Sound Definitions
[f=0000000] [Sound]  parsed 4 sounds from gamedata/sounds.lua
[f=0000000] Game::LoadDefs (Sound): 15 ms
[f=0000000] Parsing Map Information
[f=0000000] Loading SMF
[f=0000000] Loading Map (90 MB)
[f=0000000] Creating Smooth Height Mesh
[f=0000000] SmoothHeightMesh::MakeSmoothMesh: 166 ms
[f=0000000] Creating QuadField & CEGs
[f=0000000] Number of damage types: 17
[f=0000000] [RegisterAssimpModelParsers] supported Assimp model formats: *.3d;*.3ds;*.ac;*.ac3d;*.acc;*.ase;*.ask;*.b3d;*.blend;*.bvh;*.cob;*.csm;*.dae;
*.dxf;*.enff;*.hmp;*.ifc;*.irr;*.irrmesh;*.lwo;*.lws;*.lxo;*.md2;*.md3;*.md5anim;
*.md5camera;*.md5mesh;*.mdc;*.mdl;*.mesh.xml;*.mot;*.ms3d;*.ndo;*.nff;*.obj;*.off;
*.pk3;*.ply;*.prj;*.q3o;*.q3s;*.raw;*.scn;*.smd;*.stl;*.ter;*.uc;*.vta;*.x;*.xml;
[f=0000000] Creating Unit Textures
[f=0000000] Loading Weapon Definitions
I would attach the full infolog.txt if I could. Does the OS X release work for anyone (with different hardware? I have a late 2006 macbook with the ever-shitty Intel GMA 950).
0 x

abma
Spring Developer
Posts: 3575
Joined: 01 Jun 2009, 00:08

Re: Release: Spring 84.0! The DragonSlayer!

Post by abma »

@zoggop:
can you please paste infolog.txt to http://pastebin.com/ + post link here?
0 x


User avatar
KingRaptor
Zero-K Developer
Posts: 838
Joined: 14 Mar 2007, 03:44

Re: Release: Spring 84.0! The DragonSlayer!

Post by KingRaptor »

Code: Select all

 - replace engine start point marker with lua-widget
If this refers to map markers on changing start position before game start, it doesn't seem to be in Spring/examples (the one there only works at game start). Could someone point to where it is?
0 x

User avatar
AF
AI Developer
Posts: 20671
Joined: 14 Sep 2004, 11:32

Re: Release: Spring 84.0! The DragonSlayer!

Post by AF »

Could anyone running Shard master on v84 let me know of any issues? I'm aware it builds on Linux and Mac, but I can't build locally for windows, so I'm in the dark at the moment
0 x

User avatar
marciolino
Posts: 268
Joined: 06 Sep 2010, 22:59

Re: Release: Spring 84.0! The DragonSlayer!

Post by marciolino »

So this is my bug report, after some time ingame my spring crash and this is my infolog:

www.marciomarim.com/pastebin/infolog.txt

In addition, why we can no more rejoin a game?
0 x

Post Reply

Return to “News”