Test build for 0.82

Test build for 0.82

Discuss Spring news, such as fresh releases and press coverage, here.
Post Reply
Tobi
Spring Developer
Posts: 4598
Joined: 01 Jun 2005, 11:36

Test build for 0.82

Post by Tobi »

With this post I'd like to urge everyone to test the following build from the latest Spring sourcecode, and tell us whether it works correctly or not. When it does not work correctly, please back up your statement by filing a bug in our bug tracker.

Here is a link to the installer:

http://springrts.com/dl/buildbot/defaul ... 7e87ab.exe

Other related files can found here:

http://springrts.com/dl/buildbot/defaul ... -ge7e87ab/

The source code can be checked out from github commit e7e87ab.

On Linux this code can be build by following approximately these steps:
  • git clone git://github.com/spring/spring.git
  • cd spring
  • git checkout e7e87ab
  • continue with compile/install steps as usual
0 x

Auswaschbar
Spring Developer
Posts: 1254
Joined: 24 Jun 2007, 08:34

Re: Test build for 0.82

Post by Auswaschbar »

Time to build it is increased big time when all of GML / HL / default are build. Are there any flags to disable / enable them seperately?

Apart from that, build worked nicely, will do some test later on.
0 x

User avatar
jK
Spring Developer
Posts: 2299
Joined: 28 Jun 2007, 07:30

Re: Test build for 0.82

Post by jK »

Auswaschbar wrote:Time to build it is increased big time when all of GML / HL / default are build. Are there any flags to disable / enable them seperately?

Apart from that, build worked nicely, will do some test later on.

Code: Select all

make spring
0 x

Auswaschbar
Spring Developer
Posts: 1254
Joined: 24 Jun 2007, 08:34

Re: Test build for 0.82

Post by Auswaschbar »

Fabulous, but it will build the remaining stuff when "make install"ing, unless I miss something obvious.
0 x

Tobi
Spring Developer
Posts: 4598
Joined: 01 Jun 2005, 11:36

Re: Test build for 0.82

Post by Tobi »

For that, we should have `make install-spring' now.
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4343
Joined: 22 Sep 2007, 09:51

Re: Test build for 0.82

Post by hoijui »

please join #playtest
0 x

User avatar
TheFatController
Balanced Annihilation Developer
Posts: 1177
Joined: 10 Dec 2006, 18:46

Re: Test build for 0.82

Post by TheFatController »

When I looked at this in June I came up with
http://consternationstation.com/files/BA713beta.sd7 for BA if anyone else fancies running some tests.

I will however also look into this newer version this evening too.
0 x

User avatar
bibim
Lobby Developer
Posts: 913
Joined: 06 Dec 2007, 11:12

Re: Test build for 0.82

Post by bibim »

SpadsGit is currently running Spring version e7e87ab with BA713beta on springlobby.info lobby server.
This version of SPADS should support spoof protection through script passwords and in-game (re)join, but I can't test it easily right now.
0 x

User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7024
Joined: 16 Nov 2004, 13:08

Re: Test build for 0.82

Post by zwzsg »

It doesn't work:

The error box I get.

The infolog.

I set the graphic to the min, same error.
0 x

Satirik
Lobby Developer
Posts: 1688
Joined: 16 Mar 2007, 18:27

Re: Test build for 0.82

Post by Satirik »

zwzsg wrote:It doesn't work:

The error box I get.

The infolog.

I set the graphic to the min, same error.
doesn't spring need at least GL 1.4 ?
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4343
Joined: 22 Sep 2007, 09:51

Re: Test build for 0.82

Post by hoijui »

indeed, your GFX setup looks quite borked...
you should not be able to run the release version on that machine either.
0 x

User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7024
Joined: 16 Nov 2004, 13:08

Re: Test build for 0.82

Post by zwzsg »

Uh, I guess my graphic card just died then. :cry:
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4343
Joined: 22 Sep 2007, 09:51

Re: Test build for 0.82

Post by hoijui »

it looks more like your driver got fucked up, maybe use one of those driver cleaner programs and reinstall.
0 x

User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7024
Joined: 16 Nov 2004, 13:08

Re: Test build for 0.82

Post by zwzsg »

I'm confused, I only have that issue in windowed mode (both with 0.82 and 0.81), but in full screen mode, it works (both in 0.82 and 0.81). Anyway, so the problem is not related to that 0.82, feel free to delete my posts or split thread.


____________________

CreateUnitRulesParams is gone. But as jK said, if in trepan gadgets, they can just be deleted as they are followed by a SetUnitRulesParam.

Every I use Spring.Restart, the old Spring ends with an error. The new Spring is properly launched though: http://uppix.net/1/e/1/60feeebb8d81fd25 ... 8c341b.png
0 x

Post Reply

Return to “News”