KAIK 0.13 Unofficial (Spring 0.80.5*) - Page 9

KAIK 0.13 Unofficial (Spring 0.80.5*)

Here is where ideas can be collected for the skirmish AI in development

Moderators: hoijui, Moderators

Kloot
Spring Developer
Posts: 1865
Joined: 08 Oct 2006, 16:58

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by Kloot » 18 Apr 2008, 19:58

I doubt you're alone in this, it's just that not many people
(of the few that even play against AI's) unfortunately ever
report bugs, let alone any so obscure as this one. ;) New
build (with logging enabled and a custom script parser) is
here:

http://www.darkstars.co.uk/downloads/vi ... ows.tar.gz

Whether it works or not, thank you.
0 x

merijn
Posts: 59
Joined: 17 Feb 2007, 18:43

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by merijn » 19 Apr 2008, 00:10

Allright, i tried alot of different combinations, and I haven't been able to reproduce the problem. I am quite hopeful you buried that bastard for good ;-)
0 x

YokoZar
Posts: 883
Joined: 15 Jul 2007, 22:02

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by YokoZar » 27 Apr 2008, 14:40

The KAIK (and KAI, for that matter) in imbaczek's next Git repository are causing hardlocks for me again on Linux in AMD64.
0 x

Kloot
Spring Developer
Posts: 1865
Joined: 08 Oct 2006, 16:58

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by Kloot » 27 Apr 2008, 14:52

It's because the AI sources in /next are basically as they were in
76b1, ie. without any of the updates and bugfixes applied since
then (which is why I would prefer that KAIK were excluded from a
possible release based on imbaczek's branch, but that's beyond
my control).

PS. KAI 0.2 never received a fix for that specific issue AFAIK, so it
will crash regardless.
0 x

imbaczek
Posts: 3629
Joined: 22 Aug 2006, 16:19

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by imbaczek » 27 Apr 2008, 18:51

i can cherry-pick the fix, if it's relatively self-confined. will accept a patch, too.

the reason I didn't backport any AI patches is that I have no idea what changed in the AI interface and didn't want to bother with testing every single commit. if you can compile a list of commits to backport, i'll do that. (even better, make a separate branch on gitorious and do it yourself ^^ merging will be easy then.)
0 x

YokoZar
Posts: 883
Joined: 15 Jul 2007, 22:02

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by YokoZar » 02 May 2008, 09:40

imbaczek wrote:i can cherry-pick the fix, if it's relatively self-confined. will accept a patch, too.

the reason I didn't backport any AI patches is that I have no idea what changed in the AI interface and didn't want to bother with testing every single commit. if you can compile a list of commits to backport, i'll do that. (even better, make a separate branch on gitorious and do it yourself ^^ merging will be easy then.)
Yes please do this Kloot I lost track of which patch fixes things on 64 bit :)

Thank you muchly
0 x

imbaczek
Posts: 3629
Joined: 22 Aug 2006, 16:19

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by imbaczek » 02 May 2008, 16:24

I found the commit which claims to fix the issue and cherrypicked it into next. Need input on CA crash (I'm not sure that my fix is correct, if anyone can ack/nak, here's the link.)
0 x

Kloot
Spring Developer
Posts: 1865
Joined: 08 Oct 2006, 16:58

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by Kloot » 02 May 2008, 22:38

imbaczek wrote:i can cherry-pick the fix, if it's relatively self-confined. will accept a patch, too.

the reason I didn't backport any AI patches is that I have no idea what changed in the AI interface and didn't want to bother with testing every single commit. if you can compile a list of commits to backport, i'll do that. (even better, make a separate branch on gitorious and do it yourself ^^ merging will be easy then.)
Backporting everything would be redundant, the source tree I used to
build V4 already contains all of them. I don't want to maintain that one
any longer than necessary though, keeping track of two branches is a
PITA especially as 76b1/next and SVN Spring start to diverge more. If I
find the time I'll migrate it (V4) to git, but no deadlines on delivery. ;)
0 x

imbaczek
Posts: 3629
Joined: 22 Aug 2006, 16:19

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by imbaczek » 02 May 2008, 22:49

ok I found the 64-bit revision and it applied cleanly to next. now just need a tester. haven't backported anything else.
0 x

Kloot
Spring Developer
Posts: 1865
Joined: 08 Oct 2006, 16:58

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by Kloot » 02 May 2008, 23:04

Nice. Incidentally, since you mentioned CA, be aware that KAIK from
next/ won't tolerate it either without r5415 (I suppose non-crashing
non-up-to-date versions are better than crashing old ones).
0 x

imbaczek
Posts: 3629
Joined: 22 Aug 2006, 16:19

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by imbaczek » 03 May 2008, 02:44

ok, I backported most of KAIK work into next. it compiles and works.
0 x

Kloot
Spring Developer
Posts: 1865
Joined: 08 Oct 2006, 16:58

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by Kloot » 03 May 2008, 04:13

Great, all that leaves unresolved in next/ is merijn's old issue
(fortunately the fix for that is more or less self-contained too,
I'll have it on gitorious in a few days).
0 x

User avatar
Hoi
Posts: 2912
Joined: 13 May 2008, 16:51

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by Hoi » 16 May 2008, 16:41

i like the ai, but the only thing i dont like(every ai i've used has this problem) is that, in the middle of a fight a stupid constructor comes and makes something stupid like a wind generator instead of a turret that can help attack, this is very annoying, will that ever be 'fixed'?
0 x

User avatar
1v0ry_k1ng
Posts: 4656
Joined: 10 Mar 2006, 10:24

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by 1v0ry_k1ng » 16 May 2008, 18:44

anything on making s44 infantry (builders with weapons) behave as units instead of builders?
0 x

Kloot
Spring Developer
Posts: 1865
Joined: 08 Oct 2006, 16:58

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by Kloot » 17 May 2008, 12:03

It's been possible for a while:

1) remove AI/KAIK/CFGs/S44.cfg
2) run KAIK with S44, close Spring after startup
3) open AI/KAIK/CFGs/S44.cfg
4) look up the names of the infantry units
5) change the value in the last column from 4 to 9
0 x

merijn
Posts: 59
Joined: 17 Feb 2007, 18:43

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by merijn » 25 May 2008, 20:47

http://pastebin.ca/1029066

Had an assertion failed while playing XTA44 mod with KAIK013-76b1-v4-LOG.dll (on vista). Unfortunately the screenshot of the assertion message failed :/
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by hoijui » 12 Oct 2008, 10:17

Hello Kloot,
I have some questions:
is the KAIK source in trunk the latest/current one?
if not, where is the latest source?
i compiled KAIK from trunk, for 0.77, and there is a problem:
KAIK comes as usual, but when it reaches my units, it keeps walking around in a the maximum shooting distance of its units, but it does not fire. sometimes it does fire, but very casually. i had a single LLT of mine destroy a whole level one army with taking only 2 shots for example.
0 x

merijn
Posts: 59
Joined: 17 Feb 2007, 18:43

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by merijn » 13 Oct 2008, 00:37

Probably related to above post:

Several times I had the AI stop firing on me and my allies. This happens a short while into the game. Only the enemy turrets still seem to fire.

When i cheat and switch to the bot team, all units and factories are on "hold fire". After I do a cntr-a and set it to fire at will, the problem seems to be resolved for the rest of the match.

I have only played XTA (9.51) so might be mod related, not sure.

I also noticed very slow reaction times in AI bots (units), but i didn't notice this in the last game. Might be load related but need to test it more.
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by hoijui » 13 Oct 2008, 08:31

My tests were with BA. I did not notice the very slow reaction.. but could be it was there.
0 x

User avatar
DJ
Posts: 355
Joined: 17 Jan 2007, 13:26

Re: KAIK 0.13 Unofficial (Spring 0.76b1)

Post by DJ » 13 Oct 2008, 10:46

I've noticed this as well, something is definitely borked at the moment.
0 x

Post Reply

Return to “AI”