Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Discuss the source code and development of Spring Engine in general from a technical point of view. Patches go here too.

Moderator: Moderators

Post Reply
abma
Spring Developer
Posts: 3717
Joined: 01 Jun 2009, 00:08

Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by abma »

New testing release for preparing 95.0!

Most changes are bugfixes, only some few new features were introduced:
- add LuaIntro (allows custom loadscreens!)
- fix crash in KAIK
- improved performance
- ...

For details of changes since 94.1 look at the "95.0" section in changelog.txt.

See the Testing Release Wiki page for general info about how to obtain the release, and an archive of all testing releases since the last stable one.

If you find a bugs, please report to Mantis.

Remember to attach infolog.txt as file, if you crash!

sadly the macosx build still fails, still help needed! http://springrts.com/mantis/view.php?id=3816

Is 94.1.1-693-g5717870 better than 94.1? if so, i guess we can make a release.
User avatar
Silentwings
Moderator
Posts: 3695
Joined: 25 Oct 2008, 00:23

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by Silentwings »

Cool, testing :) Is Spring.Restart working yet? I didn't see it on changelog.
abma
Spring Developer
Posts: 3717
Joined: 01 Jun 2009, 00:08

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by abma »

Silentwings wrote:Is Spring.Restart working yet?
no related change, sorry :-|
User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14657
Joined: 17 Nov 2005, 02:43

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by Forboding Angel »

Zoom and scrolling are still super jerky on all cameras with 250 fps which gives the illusion of lag. Rotating camera is butter smooth.
varikonniemi
Posts: 450
Joined: 03 Jul 2011, 11:54

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by varikonniemi »

The requested URL /dl/buildbot/default/develop/94.1.1-693-g5717870/linux64/spring_{develop}94.1.1-693-g5717870_minimal-portable-linux-static.7z was not found on this server.

PLEASE take the time to test this carefully before release. I don't think the community can take another botched release. Don't release with outstanding bugs, like Forb's jerky camera.
abma
Spring Developer
Posts: 3717
Joined: 01 Jun 2009, 00:08

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by abma »

User avatar
jK
Spring Developer
Posts: 2299
Joined: 28 Jun 2007, 07:30

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by jK »

fixed dl links
abma
Spring Developer
Posts: 3717
Joined: 01 Jun 2009, 00:08

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by abma »

aww, oops, thx :-|

i'm fighting to much battles at once it seems...
raaar
Metal Factions Developer
Posts: 944
Joined: 20 Feb 2010, 12:17

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by raaar »

For now it seems to be working nicely.

sadly, can't play on the official server.

The water texture seems to have changed.

EDIT: nvm, just had to change "DisableVersionCheck=0 --> 1" in springlobby.conf. Played an 1v1 and it worked fine.
Last edited by raaar on 14 Jul 2013, 00:58, edited 1 time in total.
varikonniemi
Posts: 450
Joined: 03 Jul 2011, 11:54

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by varikonniemi »

Only one problem during limited testing: the smooth scroll widget in zk svn often starts to go with full speed to bottom right when pressing mouse3. It is very annoying and makes smooth scroll impossible to use.

But it might very well be zk widget problem not engine one.

Hope the nice performance in small games translates over to big games also.
Last edited by varikonniemi on 14 Jul 2013, 08:44, edited 1 time in total.
User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14657
Joined: 17 Nov 2005, 02:43

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by Forboding Angel »

94.1.1-693-g5717870 Is definitely better, but the zoom/scroll jerkyness is definitely a release blocker.

I get about 250 fps in 94.1.1-693-g5717870 as opposed to the 50 I'm lucky to get in 94.1.
User avatar
Deadnight Warrior
Posts: 183
Joined: 08 Jun 2009, 17:59

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by Deadnight Warrior »

  • {Laser, Emg}Projectile: disable all collision-testing when ttl <= 0 these projectile types could exceed their range due to fadeout and only removed themselves (deleteMe=true) when intensity or length reached 0, so without disabling coldet (checkCol=false) range-exploits were possible
This makes it impossible to increase LaserCannon/EMG weapon range in-game with LUA Spring.SetUnitWeaponState(unitID, weapNo, "range", newRange) over the weaponDef specified maximum. It also causes units to aquire their target and start shooting lasers, but projectiles can't reach them. Seems as if the TTL is calculated from weaponDef and not unit's local weaponState. The workaround would be to increase the weapon range in weaponDef_post and set it to shorter range upon unit creation, but that will have unit's tooltip show longer range than it really is.

Also range circles rendered by engine when you point an unit and hold shift over it are incorrect on the main map, but are correct on minimap, if they where changed via LUA in-game. Affects all range circles, weapon, radar, sonar, etc. This bug is present for a long time.

If you need something to test it with, try YAAG.
User avatar
azaremoth
Cursed Developer
Posts: 548
Joined: 17 Feb 2005, 22:05

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by azaremoth »

Deadnight Warrior wrote:This makes it impossible to increase LaserCannon/EMG weapon range in-game with LUA Spring.SetUnitWeaponState(unitID, weapNo, "range", newRange) over the weaponDef specified maximum.
Yes - that causes an issue for several units in "hero auras" in the cursed. I can work around that by replacing laser cannons with different weapon types if needed.
Forboding Angel wrote:Zoom and scrolling are still super jerky on all cameras with 250 fps which gives the illusion of lag. Rotating camera is butter smooth.
I can not reproduce this - no matter what framerate I have and what camera is used - everything was running smoothly.
raaar
Metal Factions Developer
Posts: 944
Joined: 20 Feb 2010, 12:17

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by raaar »

Deadnight Warrior wrote:
  • {Laser, Emg}Projectile: disable all collision-testing when ttl <= 0 these projectile types could exceed their range due to fadeout and only removed themselves (deleteMe=true) when intensity or length reached 0, so without disabling coldet (checkCol=false) range-exploits were possible
This makes it impossible to increase LaserCannon/EMG weapon range in-game with LUA Spring.SetUnitWeaponState(unitID, weapNo, "range", newRange) over the weaponDef specified maximum. It also causes units to aquire their target and start shooting lasers, but projectiles can't reach them. Seems as if the TTL is calculated from weaponDef and not unit's local weaponState. The workaround would be to increase the weapon range in weaponDef_post and set it to shorter range upon unit creation, but that will have unit's tooltip show longer range than it really is.

Also range circles rendered by engine when you point an unit and hold shift over it are incorrect on the main map, but are correct on minimap, if they where changed via LUA in-game. Affects all range circles, weapon, radar, sonar, etc. This bug is present for a long time.

If you need something to test it with, try YAAG.
shots fired from units without any sort of lua tweak should collide with the target. If i understood correctly this seems like a serious bug, better revert and let them collide, even if just for a bit longer.
User avatar
Deadnight Warrior
Posts: 183
Joined: 08 Jun 2009, 17:59

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by Deadnight Warrior »

raaar wrote:shots fired from units without any sort of lua tweak should collide with the target. If i understood correctly this seems like a serious bug, better revert and let them collide, even if just for a bit longer.
I was refering to LaserCannon weapons who had their range increased beyond maxRange specified in weaponDefs.
User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14657
Joined: 17 Nov 2005, 02:43

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by Forboding Angel »

azaremoth wrote:
Forboding Angel wrote:Zoom and scrolling are still super jerky on all cameras with 250 fps which gives the illusion of lag. Rotating camera is butter smooth.
I can not reproduce this - no matter what framerate I have and what camera is used - everything was running smoothly.

http://springrts.com/mantis/view.php?id=3845
User avatar
Silentwings
Moderator
Posts: 3695
Joined: 25 Oct 2008, 00:23

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by Silentwings »

I can't reproduce it either - BA has some lua in it to help smoothness of scrolling, but with BA 7.78 + 94.1.1-693 the scrolling/zooming is smooth.
raaar
Metal Factions Developer
Posts: 944
Joined: 20 Feb 2010, 12:17

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by raaar »

Deadnight Warrior wrote:
raaar wrote:shots fired from units without any sort of lua tweak should collide with the target. If i understood correctly this seems like a serious bug, better revert and let them collide, even if just for a bit longer.
I was refering to LaserCannon weapons who had their range increased beyond maxRange specified in weaponDefs.
Yes, but it smelled like something that could still cause problems when firing near max range even without lua modifications. Apparently it does! (check attachment)

This should be fixed/reverted.

EDIT: the problem happens on units with lasers trying to fire at targets near max range on hills.

added another screenshot of a can, this time in xta 9.8 firing at a pulverizer on a hill, and shot going through collision box when it should be colliding.
Attachments
spring_laser_collision_fail2.jpg
(592.41 KiB) Downloaded 5 times
spring_laser_collision_fail.jpg
laser collision fail
(623.21 KiB) Downloaded 5 times
raaar
Metal Factions Developer
Posts: 944
Joined: 20 Feb 2010, 12:17

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by raaar »

There's something else.

It seems units with very low acceleration aren't being able to reach their top speed.

ex: try to get a boat with 0.01 acceleration to reach a top speed of 2.0. It won't reach that speed, maybe half.

Happens for land units too.

It's like there's some sort of drag in effect.

I don't remember having this issue before changing to the test build, but i may be wrong.

EDIT: I got around it by overriding unit acceleration in unitdefs_post.lua ( the threshold was "acceleration < maxVelocity/80" )
abma
Spring Developer
Posts: 3717
Joined: 01 Jun 2009, 00:08

Re: Engine Testing - 94.1.1-693-g5717870 (13. Jul 2013)

Post by abma »

new testing release:

http://springrts.com/phpbb/viewtopic.php?f=12&t=30793

sorry, when we didn't fix "minor" bugs: because of the lack of man power and time we focus on the big bugs and try to make a release with the goal, that it is better than the last one.

please mantis them if you think they are important, so they don't get lost.
Post Reply

Return to “Engine”