Page 1 of 2

Enabling Shadows Problem

Posted: 27 Apr 2005, 02:47
by psyc
Well, after installing spring (from the large download, the biggest one) I tried running it and it crashed. It turned out after disabling and enabling things that having shadows enabled caused spring to give the generic windows error message crash (send error report) during loading if I had shadows enabled. I've tried reinstalling and redownloading with no luck. Also I reinstalled my videocard drivers. No luck with that either.

Posted: 27 Apr 2005, 10:08
by SJ
Your video card must support some open gl extensions in order for shadows to work. So dont enable them if it doesnt work, although it shouldnt crash just turn them off in theory.

Posted: 27 Apr 2005, 16:16
by Michilus_nimbus
Is there any way to get those extensions running on a GeForce FX go5300, 64mb?

Posted: 27 Apr 2005, 17:25
by Torrasque
I've got a radeon mobility 9700 and it don't work it normal?

Posted: 27 Apr 2005, 17:32
by Sean Mirrsen
No... update drivers and it should work. It seems on ATI cards, it crashes instead of disabling shadows if they don't work.

Posted: 28 Apr 2005, 01:14
by psyc
I've got a Radeon 9800 Pro, and as I said, I updated the drivers to the catalyst 5.4, still nothing.

Posted: 28 Apr 2005, 08:02
by SJ
Well the only radeon card i have access to is a mobile9600 with some ancient drivers from FujitsuSiemens (damn is it to hard to release new drivers more often than every second year ?) and on that they work well. Fnordia has it working on a 9800 afaik.

Posted: 28 Apr 2005, 08:11
by Webbie
SJ, try the Omega drivers. They're usually up to date, and have allways worked great for my 9700 mobility. I first started using them when Half Life two came out and the old official drivers were giving me random corrupted textures.

Posted: 28 Apr 2005, 11:01
by Dwarden
Omega drivers are just official drivers + some registry tweaks ... i can reach same result using some tweaker or manual method ...

till today nobody was able prove me otherwise nor even authors of these "modded" drivers (exception was NGO and some of their's re-written opengl libs)

Posted: 28 Apr 2005, 11:36
by [K.B.] Napalm Cobra
Is there someway i could enable shadows by force of cpu alone?
Bring on my 2 fps per second!

Posted: 28 Apr 2005, 22:53
by psyc
Just an update, I tried installing the Omega Radeon drivers, no success with them either. They're based off the ATI catalyst 5.2's I believe. Current catalyst drivers is 5.4, so they're a bit dated. But again, they don't help anyway. Any other thoughts or a cpu way to do shadows?

Posted: 01 May 2005, 22:29
by psyc
:( The new patch didn't fix my shadow issue. So I figured I'd bump this topic.

Posted: 02 May 2005, 08:41
by Yargnit
Shadows are working fine on my Radeon card. *Tries to remember what version of catalyst I have* I think it's 5.4, but I'm not 100% sure. I am actually quite impressed with how good the TA models look on Spring. (Card is X800 Pro btw)

Posted: 02 May 2005, 14:59
by Sean Mirrsen
I'd like to yet again point it out to the SY that when the primary set of extensions for shadows isn't fully available, the replacement set sometimes fails to correctly display shadows. I had this problem after modifying the EXE file, but it seems some people have this problem with the normal exe.

Posted: 02 May 2005, 15:21
by psyc
Not sure if what you're talking about, the replacement EXE, has been made available to the public, but if it is how do I test/make use of it?

And Yargnit, if you wouldn't mind, can you post your system specs?

I've got:

AMD Athlon 64 3500 939
2048MB DDR 400 RAM
Radeon 9800 Pro
Asus A8V Motherboard
Onboard sound

I'm not home right now, but I could post a dxdiag.txt if you think it would be any help.

Posted: 02 May 2005, 20:44
by Sean Mirrsen
Uh... the replacement exe? Did you, by any chance, get it from FileUniverse?

Posted: 02 May 2005, 21:10
by psyc
My mistake, when you talked about the replacement set of shadows (not sure what that is) and the modified exe I got confused. I don't have a modified version of TA Spring.

Posted: 03 May 2005, 01:35
by chillaaa
I've got:

AMD Athlon 64 3500 939
2048MB DDR 400 RAM
Radeon 9800 Pro
Asus A8V Motherboard
Onboard sound
Psyc, i have almost exactly the same system,
Athlon 64 3500
1GB DDR400
Asus A8V-E deluxe
onboard sound
Radeon X700 pro
No issues with shadows, im running Catalyst 5.4's (no control centre though)

Posted: 03 May 2005, 04:15
by Yargnit
My Specs are:

AMD 64 3200+ Socket 754 on K8t Neo (Yeah, I wish I had socket 939, but at least the 754 version of the 3200+ has 1mb L2 cache vs 512k on the 939 version)
1GB PC 3200 DDR400 RAM
Radeon X800 Pro (Catalyst 5.4)
Audiology 2 ZS

Running Win XP Pro SP2 w/direct X 9.0c (I think I have C, may just be B though)

In Catalyst I have max antialiasing & antroscopic filtering (including the new anti-aliasing they added with cat 5.4) OpenGL and Direct3d (think thats the name) are all set to max quality, and in the spring settings I have all the bars on max quality as well. I am running Spring in 1280x1024

Quick semi-on topic question for you while we are discussing systems, Spring crashes upon loading if I try 1600x1200, any idea why? (For referance I can run UT2004 on 1600x1200 with every graphic setting maxed)

Also, last Q, has anyone tried XP 64 bit, and is it worth it? (Ease of upgrade? bugs? compatibility? increased proformance?)

Posted: 04 May 2005, 02:58
by psyc
Hmm, I really have no idea what could be wrong that could be cause this to not work. I've tried multiple resolutions too, and I do have DirectX 9.0c. Any ideas for anything to reinstall/update/remove?