Current issues with 0.96 and a couple of others? - Page 2

Current issues with 0.96 and a couple of others?

Discuss your problems with the latest release of the engine here. Problems with games, maps or other utilities belong in their respective forums.

Moderator: Moderators

abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Current issues with 0.96 and a couple of others?

Post by abma »

@Capt. Fragman :

springlobby can't find your installed spring. add it by selecting in springlobby: edit->preferences->spring->add ...

if this doesn't work something is broken with unitsync.dll i guess.
Capt. Fragman
Posts: 15
Joined: 12 Jun 2010, 08:01

Re: Current issues with 0.96 and a couple of others?

Post by Capt. Fragman »

Silentwings wrote:1) Use http://www.pastebin.com.

2) You are using Spring 96.0, which is currently live, with BA V7.19, which is 3 years and 81 version numbers out of date. Update your BA to the latest (V8.00, available here: http://springrts.com/phpbb/viewtopic.php?f=44&t=32244) and you should be fine.

Thank you for the pastbin tip!

Ok this leads to a question that I posted in another thread about using older games. We (my self and 5 or 6 others that play lan and some hosted online) don't like the current ver. of BA and we do like and use some mods that worked fine like Adv. BA but don't seem to work with current versions?

Man what gives, one ver works and then 2-3 are buggy, then another one works but doesn't seem to be backward compatible etc. I know and appreciate that you guys are trying to make a great game engine but with all do respect, sometimes too many cooks can spoil the stew. Sorry my rant is over, just passing along that there used to be 30 or so of us and do to all the constant revision issues we all stopped playing. Now a year and a half later, I can only get 6 or so interested to reinstall and try to play again. Most started feeling it was just to many constant changes and problems to keep going. No disrespect intended at all, just letting you know. I DO like Spring enough that I will spend the time to try and help get it going again for myself and who ever else I can help and get them back into it.

Anyway, I don't think the few of us that are still interested want to give up what we liked. So how about some tips on how to make the older versions work?
User avatar
Silentwings
Moderator
Posts: 3686
Joined: 25 Oct 2008, 00:23

Re: Current issues with 0.96 and a couple of others?

Post by Silentwings »

Spring is developed in peoples free time - consequently no project (as far as I know) has the manpower or interest to support non-current stuff. Ranting makes absolutely no difference to that and if something "doesn't work" and it isn't the latest version of a currently maintained game being played with the current Spring version then, realistically, no one is going to give up time to fix it for you.
So how about some tips on how to make the older versions work?
Too ambiguous. If you are really wanting to live in the past and never update anything, I suggest using a LAN (http://springrts.com/wiki/Spring_on_a_LAN) and run whatever ancient Spring version coupled with whatever ancient version of some game that you used to like. Of course you may also need graphics cards etc dating from your favorite bygone times and you have about a 0% chance of getting help/support if it doesn't work.
User avatar
CarRepairer
Cursed Zero-K Developer
Posts: 3359
Joined: 07 Nov 2007, 21:48

Re: Current issues with 0.96 and a couple of others?

Post by CarRepairer »

Spawn a springie and tell it to host whichever version of spring you want. It takes all of two seconds.
Razorgaunt
Posts: 1
Joined: 07 Jul 2014, 01:51

Re: Current issues with 0.96 and a couple of others?

Post by Razorgaunt »

Not sure if this goes here, or I should start a new topic. Newb here, developer aspirant. I'm just trying to see if Spring is right for what I want to do.

Followed the directions on the "The Complete Guide to Making a Spring Game" page, loaded 0.96 Spring, grabbed the "basicexample.mod" and the "smallish map" and all that seems to work when I try to start a Singleplayer in the SpringLobby. However, when I launch the game, it crashes with an "Access violation." error message.

[EDIT] There is a warning that the examples will no longer work 100% with the new engine updates.

Here's the infolog.txt.
[ParseCmdLine] command-line args: "C:\Program Files (x86)\Spring\spring.exe C:\Users\Roger\Documents\My Games\Spring\script.txt"
Using configuration source: "C:\Users\Roger\Documents\My Games\Spring\springsettings.cfg"
Available log sections: KeyBindings, AutohostInterface, Net, CSMFGroundTextures, RoamMeshDrawer, BumpWater, DynWater, SkyBox, DecalsDrawerGL4, FarTextureHandler, Model, Piece, ModelDrawer, OBJParser, WorldObjectModelRenderer, Shader, Texture, Font, GroundMoveType, Path, UnitScript, CregSerializer, ArchiveScanner, VFS, Sound, LuaSocket
Enabled log sections: Sound(LOG_LEVEL_INFO)
Enable or disable log sections using the LogSections configuration key
or the SPRING_LOG_SECTIONS environment variable (both comma separated).
Use "none" to disable the default log sections.
LogOutput initialized.
Spring 96.0
Build date/time: Jan 3 2014 14:01:37
Build environment: boost-105300, GNU libstdc++ version 20130531
Compiler: gcc-4.8.1
OS: Microsoft Windows
Microsoft Windows 7 Home Premium Edition, 64-bit Service Pack 1 (build 7601)
Intel(R) Core(TM) i5 CPU 750 @ 2.67GHz; 4094MB RAM, 8186MB pagefile
OS: emulated 32bit mode
[CMyMath::Init] CPU SSE mask: 127, flags:
SSE 1.0: 1, SSE 2.0: 1
SSE 3.0: 1, SSSE 3.0: 1
SSE 4.1: 1, SSE 4.2: 1
SSE 4.0A: 0, SSE 5.0A: 0
using streflop SSE FP-math mode, CPU supports SSE instructions
Supported Video modes: 1920x1080, 1680x1050, 1600x900, 1440x900, 1366x768, 1360x1024, 1360x768, 1280x1024, 1280x960, 1280x800, 1280x768, 1280x720, 1152x864, 1024x768, 800x600, 720x576, 720x480, 640x480
[SetSDLVideoMode] video mode set to 1920x1080/32bit
[WatchDogInstall] Installed (HangTimeout: 10sec)
[ThreadPool::SetThreadCount][1] #wanted=4 #current=1
[ThreadPool::SetThreadCount][2] #threads=3
Using read-write data directory: C:\Users\Roger\Documents\My Games\Spring\
Using read-only data directory: C:\Program Files (x86)\Spring\
Scanning: C:\Program Files (x86)\Spring\maps
Scanning: C:\Program Files (x86)\Spring\base
Scanning: C:\Program Files (x86)\Spring\games
Scanning: C:\Users\Roger\Documents\My Games\Spring\maps
Scanning: C:\Users\Roger\Documents\My Games\Spring\games
[ThreadPool::SetThreadCount][1] #wanted=3 #current=4
[ThreadPool::SetThreadCount][2] #threads=2
[Threading] Main thread CPU affinity not set
[f=0000000] SDL version: 1.2.10
[f=0000000] GL version: 4.4.12874 Compatibility Profile Context 14.100.0.0
[f=0000000] GL vendor: ATI Technologies Inc.
[f=0000000] GL renderer: AMD Radeon R7 200 Series
[f=0000000] GLSL version: 4.30
[f=0000000] GLEW version: 1.5.8
[f=0000000] Video RAM: unknown
[f=0000000] GL info:
haveARB: 1, haveGLSL: 1, ATI hacks: 1
FBO support: 1, NPOT-texture support: 1, 24bit Z-buffer support: 0
maximum texture size: 16384, compress MIP-map textures: 0
maximum SmoothPointSize: 63, maximum vec4 varying/attributes: 32/29
maximum drawbuffers: 8, maximum recommended indices/vertices: 16777215/2147483647
number of UniformBufferBindings: 75 (64kB)
[f=0000000] VSync disabled
[f=0000000] Joysticks found: 0
[f=0000000] Warning: Joystick 0 not found
[f=0000000] [Initialize] CPU Clock: win32::TimeGetTime
[f=0000000] [Initialize] CPU Cores: 4
[f=0000000] [Startup] loading startscript from: C:\Users\Roger\Documents\My Games\Spring\script.txt
[f=0000000] Connecting to local server
[f=0000000] Binding UDP socket to IP (v6) :: port 8452
[f=0000000] [UDPListener] successfully bound socket on port 8452
[f=0000000] PreGame::StartServer: 7 ms
[f=0000000] Using map: Small Supreme Battlefield V2
[f=0000000] Using game: Example Mod
[f=0000000] Using game archive: mainmod.sdz
[f=0000000] recording demo: demos/20140706_165950_Small Supreme Battlefield V2_96.sdf
[f=0000000] PreGame::GameDataReceived: 13 ms
[f=0000000] [PreGame::UpdateClientNet] user number 0 (team 1, allyteam 0)
[f=0000000] [LuaIntro] Searching for new Widgets
[f=0000000] [LuaIntro] Scanning: LuaIntro/Addons/
[f=0000000] [LuaIntro] Scanning: LuaIntro/Widgets/
[f=0000000] [LuaIntro] Scanning: LuaIntro/SystemAddons/
[f=0000000] [LuaIntro] Scanning: LuaIntro/SystemWidgets/
[f=0000000] [LuaIntro] Scanning: LuaIntro/chili/
[f=0000000] [LuaIntro] Found new widget "SpringLogo"
[f=0000000] [LuaIntro] Found new widget "LoadTexture"
[f=0000000] [LuaIntro] Found new widget "LoadProgress"
[f=0000000] [LuaIntro] Found new widget "Main"
[f=0000000] [LuaIntro] Found new widget "Music"
[f=0000000] [LuaIntro] Loading widgets <>=vfs **=raw ()=unknown
[f=0000000] [LuaIntro] Loading widget: LoadProgress <loadprogress.lua>
[f=0000000] [Sound] OpenAL info:
[f=0000000] [Sound] Available Devices:
[f=0000000] [Sound] DirectSound Software
[f=0000000] [Sound] Device: DirectSound Software
[f=0000000] [Sound] Vendor: OpenAL Community
[f=0000000] [Sound] Version: 1.1 ALSOFT 1.11.753
[f=0000000] [Sound] Renderer: OpenAL Soft
[f=0000000] [Sound] AL Extensions: AL_EXTX_buffer_sub_data AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_OFFSET AL_EXTX_sample_buffer_object AL_EXT_source_distance_model AL_LOKI_quadriphonic
[f=0000000] [Sound] ALC Extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_disconnect ALC_EXT_EFX ALC_EXTX_thread_local_context
[f=0000000] [Sound] EFX Enabled: yes
[f=0000000] [Sound] Max Sounds: 128
[f=0000000] [LuaIntro] Loading widget: Main <main.lua>
[f=0000000] [LuaIntro] Loading widget: Music <music.lua>
[f=0000000] [LuaIntro] Error: Failed to load: bg_texture.lua (error = 2, LuaIntro/Addons/bg_texture.lua, [string "LuaIntro/Addons/bg_texture.lua"]:18: bad argument #1 to 'random' (interval is empty))
[f=0000000] [LuaIntro] LuaIntro v1.0 (Lua 5.1)
[f=0000000] Parsing Map Information
[f=0000000] Loading SMF
[f=0000000] Loading Map (103 MB)
[f=0000000] Loading Radar Icons
[f=0000000] Loading GameData Definitions
[f=0000000] Loading all definitions: 0.005000
[f=0000000] Game::LoadDefs (GameData): 6 ms
[f=0000000] Loading Sound Definitions
[f=0000000] [Sound] parsed 4 sounds from gamedata/sounds.lua
[f=0000000] [Sound] Error: Unable to open audio file: sounds/incoming_chat.wav
[f=0000000] Game::LoadDefs (Sound): 0 ms
[f=0000000] Creating Smooth Height Mesh
[f=0000000] SmoothHeightMesh::MakeSmoothMesh: 63 ms
[f=0000000] Creating QuadField & CEGs
[f=0000000] [CDamageArrayHandler] number of ArmorDefs: 1
[f=0000000] [RegisterAssimpModelFormats] supported Assimp model formats: *.3ds;*.blend;*.dae;*.lwo;
[f=0000000] Creating Unit Textures
[f=0000000] Creating Sky
[f=0000000] Loading Weapon Definitions
[f=0000000] Loading Unit Definitions
[f=0000000] Error: Couldn't find WeaponDef NOWEAPON and explodeAs for base is missing!
[f=0000000] Error: Couldn't find WeaponDef NOWEAPON and selfDestructAs for base is missing!
[f=0000000] Error: Couldn't find WeaponDef NOWEAPON and explodeAs for builder is missing!
[f=0000000] Error: Couldn't find WeaponDef NOWEAPON and selfDestructAs for builder is missing!
[f=0000000] Error: Couldn't find WeaponDef NOWEAPON and explodeAs for building is missing!
[f=0000000] Error: Couldn't find WeaponDef NOWEAPON and selfDestructAs for building is missing!
[f=0000000] Warning: building: Given yardmap requires 3 extra char(s)!
[f=0000000] Error: Couldn't find WeaponDef NOWEAPON and explodeAs for tank is missing!
[f=0000000] Error: Couldn't find WeaponDef NOWEAPON and selfDestructAs for tank is missing!
[f=0000000] Loading Feature Definitions
[f=0000000] Reading Estimate PathCosts [8]
[f=0000000] Reading Estimate PathCosts [32]
[f=0000000] [CPathManager] pathing data checksum: 6b02ee8b
[f=0000000] [IPathManager::GetInstance] using DEFAULT path-manager
[f=0000000] Initializing Map Features
[f=0000000] [Sound] Error: Unable to open audio file: sounds/mappoint.wav
[f=0000000] Creating ShadowHandler & DecalHandler
[f=0000000] FBO::maxSamples: 8
[f=0000000] Error: Spring 96.0 has crashed.
[f=0000000] Error: DLL information:
[f=0000000] Error: 0x00400000 spring
[f=0000000] Error: 0x77680000 ntdll
[f=0000000] Error: 0x76f00000 kernel32
[f=0000000] Error: 0x75360000 KERNELBASE
[f=0000000] Error: 0x752c0000 ADVAPI32
[f=0000000] Error: 0x77010000 msvcrt
[f=0000000] Error: 0x75220000 sechost
[f=0000000] Error: 0x76e10000 RPCRT4
[f=0000000] Error: 0x75080000 SspiCli
[f=0000000] Error: 0x75070000 CRYPTBASE
[f=0000000] Error: 0x5e4e0000 GLU32
[f=0000000] Error: 0x55610000 OPENGL32
[f=0000000] Error: 0x75190000 GDI32
[f=0000000] Error: 0x76660000 USER32
[f=0000000] Error: 0x75630000 LPK
[f=0000000] Error: 0x750e0000 USP10
[f=0000000] Error: 0x6a1f0000 DDRAW
[f=0000000] Error: 0x6f7c0000 DCIMAN32
[f=0000000] Error: 0x75640000 SETUPAPI
[f=0000000] Error: 0x76af0000 CFGMGR32
[f=0000000] Error: 0x767c0000 OLEAUT32
[f=0000000] Error: 0x75490000 ole32
[f=0000000] Error: 0x76dc0000 DEVOBJ
[f=0000000] Error: 0x6fd40000 dwmapi
[f=0000000] Error: 0x76b30000 IMAGEHLP
[f=0000000] Error: 0x75a10000 SHELL32
[f=0000000] Error: 0x75250000 SHLWAPI
[f=0000000] Error: 0x724d0000 WINMM
[f=0000000] Error: 0x755f0000 WS2_32
[f=0000000] Error: 0x767b0000 NSI
[f=0000000] Error: 0x10000000 DevIL
[f=0000000] Error: 0x5bf60000 MSVCP80
[f=0000000] Error: 0x73890000 MSVCR80
[f=0000000] Error: 0x6b600000 OpenAL32
[f=0000000] Error: 0x70780000 vorbisfile
[f=0000000] Error: 0x68140000 ogg
[f=0000000] Error: 0x64cc0000 vorbis
[f=0000000] Error: 0x62e80000 zlib1
[f=0000000] Error: 0x66fc0000 freetype6
[f=0000000] Error: 0x62aa0000 glew32
[f=0000000] Error: 0x00330000 SDL
[f=0000000] Error: 0x7c340000 MSVCR71
[f=0000000] Error: 0x757e0000 IMM32
[f=0000000] Error: 0x753b0000 MSCTF
[f=0000000] Error: 0x67a70000 dsound
[f=0000000] Error: 0x6d200000 POWRPROF
[f=0000000] Error: 0x76c90000 CLBCatQ
[f=0000000] Error: 0x6d1c0000 MMDevApi
[f=0000000] Error: 0x74de0000 PROPSYS
[f=0000000] Error: 0x72c60000 wdmaud
[f=0000000] Error: 0x72c50000 ksuser
[f=0000000] Error: 0x72680000 AVRT
[f=0000000] Error: 0x6d230000 AUDIOSES
[f=0000000] Error: 0x72670000 msacm32
[f=0000000] Error: 0x6fd80000 MSACM32
[f=0000000] Error: 0x72660000 midimap
[f=0000000] Error: 0x5cf30000 nvapi
[f=0000000] Error: 0x74fa0000 VERSION
[f=0000000] Error: 0x76de0000 WINTRUST
[f=0000000] Error: 0x76b70000 CRYPT32
[f=0000000] Error: 0x76b20000 MSASN1
[f=0000000] Error: 0x77650000 profapi
[f=0000000] Error: 0x70ce0000 uxtheme
[f=0000000] Error: 0x6aab0000 ltc_help32-82061
[f=0000000] Error: 0x6aa40000 atiglpxx
[f=0000000] Error: 0x68800000 atioglxx
[f=0000000] Error: 0x5bb50000 atiadlxy
[f=0000000] Error: 0x76da0000 USERENV
[f=0000000] Error: 0x70960000 WTSAPI32
[f=0000000] Error: 0x76ae0000 PSAPI
[f=0000000] Error: 0x724b0000 IPHLPAPI
[f=0000000] Error: 0x72350000 WINNSI
[f=0000000] Error: 0x6aa10000 atigktxx
[f=0000000] Error: 0x6c680000 DINPUT
[f=0000000] Error: 0x6fbc0000 HID
[f=0000000] Error: 0x064a0000 mswsock
[f=0000000] Error: 0x6cf30000 wship6
[f=0000000] Error: 0x70750000 wshtcpip
[f=0000000] Error: 0x6f5d0000 dbghelp
[f=0000000] Error: Exception: Access violation (0xc0000005)
[f=0000000] Error: Exception Address: 0x688cd295
[f=0000000] Error: Stacktrace for Spring 96.0:
[f=0000000] Error: This stack trace indicates a problem with your graphic card driver. Please try upgrading or downgrading it. Specifically recommended is the latest driver, and one that is as old as your graphic card. Make sure to use a driver removal utility, before installing other drivers.
[f=0000000] Error: (0) C:\Windows\system32\atioglxx.dll(DrvPresentBuffers+0x29665) [0x688CD295]
[f=0000000] Error: (1) C:\Windows\system32\atioglxx.dll(DrvPresentBuffers+0x3225b) [0x688D5E8B]
[f=0000000] Error: (2) C:\Windows\system32\atioglxx.dll(DrvPresentBuffers+0x785746) [0x69029376]
[f=0000000] Error: (3) C:\Program Files (x86)\Spring\spring.exe [0x006E15C6]
[f=0000000] Error: (4) C:\Program Files (x86)\Spring\spring.exe [0x006E3F66]
[f=0000000] Error: (5) C:\Program Files (x86)\Spring\spring.exe [0x006E79A4]
[f=0000000] Error: (6) C:\Program Files (x86)\Spring\spring.exe [0x006E8D85]
[f=0000000] Error: (7) C:\Program Files (x86)\Spring\spring.exe [0x0070F1DB]
[f=0000000] Error: (8) C:\Program Files (x86)\Spring\spring.exe [0x004255DF]
[f=0000000] Error: (9) C:\Program Files (x86)\Spring\spring.exe(skirmishAiCallback_Cheats_setEnabled+0x3b3d55) [0x00CB65A5]
[f=0000000] Error: (10) C:\Program Files (x86)\Spring\spring.exe [0x0087A181]
[f=0000000] Error: (11) C:\Program Files (x86)\Spring\spring.exe(skirmishAiCallback_Cheats_setEnabled+0x3a7bd1) [0x00CAA421]
[f=0000000] Error: (12) C:\Program Files (x86)\Spring\spring.exe(skirmishAiCallback_Cheats_setEnabled+0x299c37) [0x00B9C487]
[f=0000000] Error: (13) C:\Windows\SysWOW64\ntdll.dll(RtlInitializeExceptionChain+0x63) [0x776B9F72]
[f=0000000] Error: (14) C:\Windows\SysWOW64\ntdll.dll(RtlInitializeExceptionChain+0x36) [0x776B9F45]
[f=0000000] Error: [ErrorMessageBox][1] msg="Spring has crashed:
Access violation.

A stacktrace has been written to:
C:\Users\Roger\Documents\My Games\Spring\infolog.txt" IsMainThread()=0 fromMain=0
[f=0000000] [SpringApp::ShutDown][1]
[f=0000000] [ThreadPool::SetThreadCount][1] #wanted=0 #current=3
[f=0000000] [ThreadPool::SetThreadCount][2] #threads=0
[f=0000000] [SpringApp::ShutDown][2]
[f=0000000] [~CGame][1]
[f=0000000] [~CGame][2]
[f=0000000] [~CGame][3]
[f=0000000] [~CGame][4]
[f=0000000] [~CGame][5]
[f=0000000] [~CGame][6]
[f=0000000] [~CGame][7]
[f=0000000] [~CGame][8]
[f=0000000] [CCollisionHandler] dis-/continuous tests: 0/0
[f=0000000] [~CGame][9]
[f=0000000] [~CGame][10]
[f=0000000] [~CPathCache(32x32)] cacheHits=0 hitPercentage=0% numHashColls=0 maxCacheSize=0
[f=0000000] [~CPathCache(32x32)] cacheHits=0 hitPercentage=0% numHashColls=0 maxCacheSize=0
[f=0000000] [~CPathCache(128x128)] cacheHits=0 hitPercentage=0% numHashColls=0 maxCacheSize=0
[f=0000000] [~CPathCache(128x128)] cacheHits=0 hitPercentage=0% numHashColls=0 maxCacheSize=0
[f=0000000] Statistics for RectangleOptimizer: 0%
[f=0000000] Statistics for RectangleOptimizer: 0%
[f=0000000] [~CGame][11]
[f=0000000] [~CGame][12]
[f=0000000] [~CGame][13]
[f=0000000] [~CGame][14]
[f=0000000] [~CGame][15]
[f=0000000] [~CGameServer][1]
[f=0000000] [~CGameServer][2]
[f=0000000] [~CGame][16]
[f=0000000] [Sound] [~CSound][1] soundThread=03270928
[f=0000000] [Sound] [~CSound][2]
[f=0000000] [Sound] [~CSound][3]
[f=0000000] [~CGame][17]
[f=0000000] [SpringApp::ShutDown][3]
[f=0000000] [SpringApp::ShutDown][4]
[f=0000000] Statistics for local connection:
Received: 462 bytes
Sent: 8 bytes

[f=0000000] Writing demo: demos/20140706_165950_Small Supreme Battlefield V2_96.sdf
[f=0000000] [SpringApp::ShutDown][5]
[f=0000000] [SpringApp::ShutDown][6]
[f=0000000] [SpringApp::ShutDown][7]
[f=0000000] [SpringApp::ShutDown][8]
[f=0000000] [SpringApp::ShutDown][9]
[SpringApp::ShutDown][10]
[SpringApp::ShutDown][11]
[WatchDog::Uninstall][1] hangDetectorThread=032707C8
[WatchDog::Uninstall][2]
[WatchDog::Uninstall][3]
[SpringApp::ShutDown][12]
[SpringApp::Run] exitCode=0
Error: [Run] ret=0 err="Spring has crashed:
Access violation.

A stacktrace has been written to:
C:\Users\Roger\Documents\My Games\Spring\infolog.txt"
Error: [ErrorMessageBox][1] msg="[Run] error: Spring has crashed:
Access violation.

A stacktrace has been written to:
C:\Users\Roger\Documents\My Games\Spring\infolog.txt" IsMainThread()=1 fromMain=1
Error: [ErrorMessageBox][2]
Error: [ErrorMessageBox][3]
Error: [ErrorMessageBox][4]
Fatal: Spring: Unhandled exception
[Run] error: Spring has crashed:
Access violation.
Last edited by Razorgaunt on 07 Jul 2014, 02:26, edited 1 time in total.
abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Current issues with 0.96 and a couple of others?

Post by abma »

[f=0000000] Error: This stack trace indicates a problem with your graphic card driver. Please try upgrading or downgrading it. Specifically recommended is the latest driver, and one that is as old as your graphic card. Make sure to use a driver removal utility, before installing other drivers.
try if it doesn't crash with "spring.exe --safemode"
Masure
Posts: 581
Joined: 30 Jan 2007, 15:23

Re: Current issues with 0.96 and a couple of others?

Post by Masure »

Make sure you have this in your springsettings.cfg :

3DTrees = 0
AdvMapShading = 0
AdvUnitShading = 0
GroundDecals = 0
ReflectiveWater = 2
Shadows = 0

Any of those settings set to 1 makes spring crash with ATI. Safe mode does not work because it does not disable all of these.
Post Reply

Return to “Help & Bugs”