ATI HD 7770 GOOD DRIVER BUT UPDATE OR DOWN DEPEND ON CONFIGF

ATI HD 7770 GOOD DRIVER BUT UPDATE OR DOWN DEPEND ON CONFIGF

Discuss your problems with the latest release of the engine here. Problems with games, maps or other utilities belong in their respective forums.

Moderator: Moderators

Post Reply
Senethril
Posts: 39
Joined: 04 Oct 2013, 18:20

ATI HD 7770 GOOD DRIVER BUT UPDATE OR DOWN DEPEND ON CONFIGF

Post by Senethril »

Hello, i want ask community if there are solutions for game crashs related to driver version.

In fact i can launch the game successfully but with a good driver version for my ati card and sometimes i need to correct or paste my springsettings.cfg

The problem is the update of driver i receive, if i install them i am sure the game will crash without any clue.

This time its the line with square in it that i remember the last in the load screen.

So the message with report to infolog.txt remain everytimes :(

What can i do except downgrade my drivers (In peripherical panel , the working version is 9.10.8.0)

Now i use 9.14.10.01029(reference to direct3d version sometimes only saw in amd control panel!)


I post new infolog, now thats bug in last line, called finalize :/
hope that ll help you.

i just tried latest amd beta and crash continue with finalize or tree drawer(settings edited with shaders shadow tree adv)

ok now i just tried put old configfile instead of "fresh file"

i foound more lines before dll information list and after square...
If i edit the config file with ROAM=0 i found same log but the line that crash the game at the end is changed from roam mash to legacy mesh, no more help.

Below the settings file i can give you and the log too

ROAM set to -1 or 0 =

Loading Square Textures
[f=0000000] CSMFGroundTextures::ConvolveHeightMap: 4 ms
[f=0000000] Switching to Legacy Mesh Rendering

ROAM set to 1 =

NORMAL LINE IS DELETED IN CONFIG

ROAM set to 2 =

[f=0000000] Switching to ROAM Mesh Rendering
[f=0000000] Set ROAM mode to DisplayLists
[f=0000000] Error: Spring 96.0 has crashed.
[f=0000000] Error: DLL information:

ROAM set to 3 =

[f=0000000] Loading Square Textures
[f=0000000] CSMFGroundTextures::ConvolveHeightMap: 21 ms
[f=0000000] Switching to ROAM Mesh Rendering
[f=0000000] Set ROAM mode to VA
[f=0000000] Error: Spring 96.0 has crashed.
[f=0000000] Error: DLL information:


I SEE NOTHING MORE THAN TreeRadius options executing spring.exe --list-config-vars > cfgdoc.txt

Set to 0

In others log , i see Creating TreeDrawer just after my last lines
Sooo that line could be the problem, when i was installing other update for graphic card i had same line problem and only one version of them is perfectly working.

HELP
(I can provide diff between the config files used for each lines but maybe its not the last line :()

I did a search and found one guy that talk about config file, all other related topic seems not good for me.

http://springrts.com/phpbb/viewtopic.ph ... r+#p507176

http://springrts.com/phpbb/viewtopic.ph ... crash+tree


I FIIINNND NOTHINGGG

3DTrees = 0
AdvMapShading = 0
CompressTextures = 1
LoadingMT = 0
LuaShaders = 0
MultiThreadCount = 1
PathingThreadCount = 1
ROAM = 2
ReflectiveWater = 0
SetCoreAffinity = 1
SetCoreAffinitySim = 1
SmoothLines = 0
SmoothPoints = 0
UseEFX = 0
UsePBO = 0
UseVBO = 0

Fullscreen=0

i tried the safemode but with without script.txt in arguments :/
Attachments
infolog2.txt
(45.98 KiB) Downloaded 4 times
springsettings.cfg
(1.74 KiB) Downloaded 5 times
infolog.txt
(45.08 KiB) Downloaded 4 times
Masure
Posts: 581
Joined: 30 Jan 2007, 15:23

Re: ATI HD 7770 GOOD DRIVER BUT UPDATE OR DOWN DEPEND ON CON

Post by Masure »

Settings that makes my Spring crash with AMD + Catalyst 14.4

3DTrees = 1
AdvMapShading = 1
AdvUnitShading = 1
ReflectiveWater = 4
GroundDecals = 1
Shadows = 1

Game is ugly without shadows.
User avatar
romulous
Posts: 39
Joined: 31 Jan 2010, 12:36

Re: ATI HD 7770 GOOD DRIVER BUT UPDATE OR DOWN DEPEND ON CON

Post by romulous »

Masure wrote:Settings that makes my Spring crash with AMD + Catalyst 14.4

3DTrees = 1
AdvMapShading = 1
AdvUnitShading = 1
ReflectiveWater = 4
GroundDecals = 1
Shadows = 1

Game is ugly without shadows.
Cool thanks, that helped me get it working with AMD 14.4 drivers. Just manually edited springsettings.cfg and added them to the end all set to 0 (zero). :-)
Post Reply

Return to “Help & Bugs”