Spring 96.0: Start Game Crash, no Commanders - Page 2

Spring 96.0: Start Game Crash, no Commanders

Discuss your problems with the latest release of the engine here. Problems with games, maps or other utilities belong in their respective forums.

Moderator: Moderators

Captain_John
Posts: 13
Joined: 21 Apr 2014, 13:04

Re: Spring 96.0: Start Game Crash, no Commanders

Post by Captain_John »

I did that before my previous post. It did not change anything. Spring is running at "High Peformance". I thought that ati hyrid configuration was something different, judging from those instructions (Monitor cables, installing programs and so on).

I ran around for a while, worked fine, then I started building and immidially Spring crashed. Access violation. Nothing new. I tried different buildings.
I also tried NOTA Mod - I start without Commander.
Pastebin: http://pastebin.com/5EPUfc1S
abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Spring 96.0: Start Game Crash, no Commanders

Post by abma »

you are still using the integrated card, not your radeon:
[f=0000000] GL renderer: Intel(R) HD Graphics Family

do you have an ati card at all?
User avatar
Jools
XTA Developer
Posts: 2814
Joined: 23 Feb 2009, 16:29

Re: Spring 96.0: Start Game Crash, no Commanders

Post by Jools »

[f=0000000] Error: Lua LoadCode pcall error = 0, LuaRules/main.lua, error = 2, LuaRules/gadgets.lua, [string "LuaRules/gadgets.lua"]:821: attempt to index global 'CallInsMap' (a nil value)
That's actually an error in the NOTA game, and if you get those errors it would prevent the spawning of the commander. You get same results with other games? Game starts but no commander?

You use newest engine 96.0 and newest NOTA 1.80 as far as I can tell.

Edit: I get same error with NOTA 1.80. I remember now that NOTA isn't yet compatible with engine 96.0, you have to use 94.1 for nota still untill they have updated it.

You can get engine 94.1 here:

http://springrts.com/dl/buildbot/defaul ... 4.1/win32/
Captain_John
Posts: 13
Joined: 21 Apr 2014, 13:04

Re: Spring 96.0: Start Game Crash, no Commanders

Post by Captain_John »

I don´t know, if I have an ATI card. I know I have a AMD Radeon HD 6470M and a Intel(R) HD Graphics Family. Driver up to date.
Also an IDE ATA/ATAPI-Controller. Does this help in any way?

I am looking all that up in the windows hardware manager.
User avatar
Jools
XTA Developer
Posts: 2814
Joined: 23 Feb 2009, 16:29

Re: Spring 96.0: Start Game Crash, no Commanders

Post by Jools »

Well, AMD bought ATI so they're all AMD now. People are just used to say ATI, but we should say AMD.

So your computer has two Graphics cards: one AMD and one Intel HD blablabla. Somehow you must order your computer to use the AMD one instead of the Intel one when starting spring, that's the problem.
klapmongool
Posts: 843
Joined: 13 Aug 2007, 13:19

Re: Spring 96.0: Start Game Crash, no Commanders

Post by klapmongool »

Jools wrote:Well, AMD bought ATI so they're all AMD now. People are just used to say ATI, but we should say AMD.

So your computer has two Graphics cards: one AMD and one Intel HD blablabla. Somehow you must order your computer to use the AMD one instead of the Intel one when starting spring, that's the problem.
I'm gonna guess he has to disable onboard graphics in the BIOS. Easy enough.
User avatar
Jools
XTA Developer
Posts: 2814
Joined: 23 Feb 2009, 16:29

Re: Spring 96.0: Start Game Crash, no Commanders

Post by Jools »

klapmongool wrote: I'm gonna guess he has to disable onboard graphics in the BIOS. Easy enough.
BIOS or UEFI. Newer computers use the latter.
abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Spring 96.0: Start Game Crash, no Commanders

Post by abma »

klapmongool wrote:I'm gonna guess he has to disable onboard graphics in the BIOS. Easy enough.
thats just wrong. he has to figure out how to enable the ati card for spring.
klapmongool
Posts: 843
Joined: 13 Aug 2007, 13:19

Re: Spring 96.0: Start Game Crash, no Commanders

Post by klapmongool »

abma wrote:
klapmongool wrote:I'm gonna guess he has to disable onboard graphics in the BIOS. Easy enough.
thats just wrong. he has to figure out how to enable the ati card for spring.
What, the onboard card is meant for power lower power use or something? My solution is otherwise fine.
abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Spring 96.0: Start Game Crash, no Commanders

Post by abma »

klapmongool wrote:What, the onboard card is meant for power lower power use or something? My solution is otherwise fine.
its maybe a workarround which breaks other stuff. maybe its not possible to disable it? maybe laptop overheats? laptop runtime heavily reduces?

you didn't mentioned these drawbacks.
User avatar
Anarchid
Posts: 1383
Joined: 30 Nov 2008, 04:31

Re: Spring 96.0: Start Game Crash, no Commanders

Post by Anarchid »

What happens if you launch the exact spring executable specified in catalyst as high-performance directly, rather than via lobby?
Masure
Posts: 581
Joined: 30 Jan 2007, 15:23

Re: Spring 96.0: Start Game Crash, no Commanders

Post by Masure »

Settings that make my Spring crash with AMD + Catalyst 14.4

3DTrees = 1
AdvMapShading = 1
AdvUnitShading = 1
ReflectiveWater = 4
GroundDecals = 1
Shadows = 1

Game is ugly without shadows.
User avatar
Jools
XTA Developer
Posts: 2814
Joined: 23 Feb 2009, 16:29

Re: Spring 96.0: Start Game Crash, no Commanders

Post by Jools »

Masure wrote: Game is ugly without shadows.
On water maps, it's a blessing in disguise. Shadows don't display correctly anyway, you're better off having them disabled.

They display on sea bed :|
Masure
Posts: 581
Joined: 30 Jan 2007, 15:23

Re: Spring 96.0: Start Game Crash, no Commanders

Post by Masure »

You mean because shadows are not beautiful on sea I should not complain and point out they make my game crash on every map ?

I don't see your point.
User avatar
Jools
XTA Developer
Posts: 2814
Joined: 23 Feb 2009, 16:29

Re: Spring 96.0: Start Game Crash, no Commanders

Post by Jools »

They confuse gameplay: you think the unit is above water when it's in fact below.
klapmongool
Posts: 843
Joined: 13 Aug 2007, 13:19

Re: Spring 96.0: Start Game Crash, no Commanders

Post by klapmongool »

abma wrote:
klapmongool wrote:What, the onboard card is meant for power lower power use or something? My solution is otherwise fine.
its maybe a workarround which breaks other stuff. maybe its not possible to disable it? maybe laptop overheats? laptop runtime heavily reduces?

you didn't mentioned these drawbacks.
Well, mentioning drawbacks of laptops now.. Yea I should have told him to get a decent pc for half the money. Did you mention the drawbacks of playing games on a laptop for hours on end? RSI ftw.
abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Spring 96.0: Start Game Crash, no Commanders

Post by abma »

klapmongool wrote:Well, mentioning drawbacks of laptops now.. Yea I should have told him to get a decent pc for half the money. Did you mention the drawbacks of playing games on a laptop for hours on end? RSI ftw.
thats off-topic ;)
Captain_John
Posts: 13
Joined: 21 Apr 2014, 13:04

Re: Spring 96.0: Start Game Crash, no Commanders

Post by Captain_John »

What happens if you launch the exact spring executable specified in catalyst as high-performance directly, rather than via lobby?
I always started Spring from the .exe. I had to add the .exe manually to the catalyst center. So yes, it´s the same file as stated in the catalyst center.
Here a screenshot: Language German. "Hochleistung" -> "High Performance"
Attachments
Spring Bug.jpg
(126.91 KiB) Not downloaded yet
Post Reply

Return to “Help & Bugs”