** Server ** Timeout assumed, disconnecting - Page 2

** Server ** Timeout assumed, disconnecting

Discuss your problems with the latest release of the engine here. Problems with games, maps or other utilities belong in their respective forums.

Moderator: Moderators

abma
Spring Developer
Posts: 3556
Joined: 01 Jun 2009, 00:08

Re: ** Server ** Timeout assumed, disconnecting

Post by abma » 27 Feb 2014, 14:59

do you have a single-core processor?
0 x

Kapytii
Posts: 64
Joined: 14 Mar 2013, 08:40

Re: ** Server ** Timeout assumed, disconnecting

Post by Kapytii » 28 Feb 2014, 14:03

Yeah hi, Ive no idea... Im not computery enough guy to know that kinda stuff :/ But its a fast computer, few years old then-top(ish)-quality so I'd assume not single core?

Also I tried turning all possible firewalls off but that didnt effect anything. Still kept "disconnecting from main server" at random times.

I'll see if I can find out anything about this single coreness from somewhere a bit later...
0 x

Kapytii
Posts: 64
Joined: 14 Mar 2013, 08:40

Re: ** Server ** Timeout assumed, disconnecting

Post by Kapytii » 28 Feb 2014, 17:50

Four cores I have.
0 x

User avatar
PicassoCT
Journeywar Developer & Mapper
Posts: 10238
Joined: 24 Jan 2006, 21:12

Re: ** Server ** Timeout assumed, disconnecting

Post by PicassoCT » 01 Mar 2014, 09:57

Not five, even six cores is totally wrong, and seven cores is totally wicked. No Four, neither three nor two, do not even consider one. No, four cores, none less, none more.


Also infolog?
0 x

luizxd5
Posts: 2
Joined: 01 Mar 2014, 23:12

Re: ** Server ** Timeout assumed, disconnecting

Post by luizxd5 » 01 Mar 2014, 23:14

Well i'm dealing with this probblem too... and i guess its not the ping situation. Waiting for a solution :D
0 x

luizxd5
Posts: 2
Joined: 01 Mar 2014, 23:12

Re: ** Server ** Timeout assumed, disconnecting

Post by luizxd5 » 01 Mar 2014, 23:16

PicassoCT wrote:Not five, even six cores is totally wrong, and seven cores is totally wicked. No Four, neither three nor two, do not even consider one. No, four cores, none less, none more.


Also infolog?
There's no infolog. Its not a hardware problem.
0 x

User avatar
PicassoCT
Journeywar Developer & Mapper
Posts: 10238
Joined: 24 Jan 2006, 21:12

Re: ** Server ** Timeout assumed, disconnecting

Post by PicassoCT » 02 Mar 2014, 01:12

its a spring lobby problem, due to multithreading or bad connection? Infolog is always usefull though, as it contains specs ?

And yeah, only skimed the thread. Sorry.
0 x

Kapytii
Posts: 64
Joined: 14 Mar 2013, 08:40

Re: ** Server ** Timeout assumed, disconnecting

Post by Kapytii » 15 Mar 2014, 06:34

Nothing has changed on this end, but the lobby has been working much better for few weeks.
0 x

abma
Spring Developer
Posts: 3556
Joined: 01 Jun 2009, 00:08

Re: ** Server ** Timeout assumed, disconnecting

Post by abma » 16 Mar 2014, 23:42

FYI: next springlobby release will have a debug message about this:

https://github.com/springlobby/springlo ... 8a4ee71409
0 x

abma
Spring Developer
Posts: 3556
Joined: 01 Jun 2009, 00:08

Re: ** Server ** Timeout assumed, disconnecting

Post by abma » 21 Mar 2014, 16:50

0.181 released, try again please :)

if you disconnect and got this message:

"SpringLobby hung for %d seconds"

please post here!
0 x

Kapytii
Posts: 64
Joined: 14 Mar 2013, 08:40

Re: ** Server ** Timeout assumed, disconnecting

Post by Kapytii » 01 Aug 2014, 15:36

No, the 0.181 didnt help back then.

Now - I dont know when exactly, a month or two ago maybe when I wasnt very active - the problem stopped and hasnt happened to this day. Whatever update then was, lobby maybe? Nothing on my computer has changed, so something spring related got better.

Please no more updates :)
0 x

abma
Spring Developer
Posts: 3556
Joined: 01 Jun 2009, 00:08

Re: ** Server ** Timeout assumed, disconnecting

Post by abma » 01 Aug 2014, 15:42

fyi: current version of springlobby is 0.196: http://springrts.com/phpbb/viewtopic.php?f=64&t=31224
0 x

Post Reply

Return to “Help & Bugs”