ATI slow performance in 0.94.x versions

ATI slow performance in 0.94.x versions

Discuss your problems with the latest release of the engine here. Problems with games, maps or other utilities belong in their respective forums.

Moderator: Moderators

ismo
Posts: 33
Joined: 27 Dec 2009, 13:52

ATI slow performance in 0.94.x versions

Post by ismo » 08 Apr 2013, 22:16

Hi all,

Noticed that Spring is now very slow in general compared to pre v0.94 time. Namely, I am getting something like 10-30fps if it is for example 3 vs 3 game and few hundreds of units on screen. Used to run 60 fps smoothly in before v0.94.

My system:
Windows 7
12GB DDR3/1600
I7 920
AMD Radeon 5850 / 2gb
Catalyst 13.1.
1920x1200 resolution

Any idea how to get it to run faster at least a bit? (except than buying nvidia card :))

Addon: I play XTA mod, have not checked if it is just slow in XTA but I guess that not.
0 x

abma
Spring Developer
Posts: 3548
Joined: 01 Jun 2009, 00:08

Re: ATI slow performance in 0.94.x versions

Post by abma » 09 Apr 2013, 08:48

do you have set LogFlush=0 ? (known bug for that release)
0 x

User avatar
Jools
XTA Developer
Posts: 2804
Joined: 23 Feb 2009, 16:29

Re: ATI slow performance in 0.94.x versions

Post by Jools » 09 Apr 2013, 09:08

I also have slow fps compared to spring 91 and before. How about setting CPU affinity to 0x01 as we used to do with previous releases, would that maybe help?
0 x

abma
Spring Developer
Posts: 3548
Joined: 01 Jun 2009, 00:08

Re: ATI slow performance in 0.94.x versions

Post by abma » 09 Apr 2013, 09:11

@ismo:

are you using mt? infolog.txt maybe helps...
0 x

ismo
Posts: 33
Joined: 27 Dec 2009, 13:52

Re: ATI slow performance in 0.94.x versions

Post by ismo » 09 Apr 2013, 16:21

Hmm not using that logFlush will try that. Infolog telling Spring 94.1 (OMP) I guess that OMP = OpenMP = multiprocessor version?

Hmm I think tasclient has only options default and multithreaded version and I use only default which I guess starts nowadays multithreaded exe? (in the past it used to start single threaded version).
0 x

zerver
Spring Developer
Posts: 1358
Joined: 16 Dec 2006, 20:59

Re: ATI slow performance in 0.94.x versions

Post by zerver » 10 Apr 2013, 01:15

ismo wrote:I guess that OMP = OpenMP = multiprocessor version?
Not meaning to be negative but the other executable (ASIM) is orders of magnitude better if your goal is high FPS.

The 94.X pathfinder is a lot more heavy on the CPU and this translates directly into lower FPS if you are using OMP.
0 x

User avatar
jK
Spring Developer
Posts: 2299
Joined: 28 Jun 2007, 07:30

Re: ATI slow performance in 0.94.x versions

Post by jK » 10 Apr 2013, 02:12

zerver wrote:The 94.X pathfinder is a lot more heavy on the CPU and this translates directly into lower FPS if you are using OMP.
Please stop your propaganda of incorrect $%^&>!
0 x

zerver
Spring Developer
Posts: 1358
Joined: 16 Dec 2006, 20:59

Re: ATI slow performance in 0.94.x versions

Post by zerver » 11 Apr 2013, 02:17

jK wrote:Please stop your propaganda of incorrect $%^&>!
Please stop making Spring slower :mrgreen:

I'm just saying that when the OMP build is busy with 100% simulation, there is no CPU left to do rendering, so zero FPS. That's a fact and no propaganda.

However, this (changelog.txt):

Code: Select all

Pathing:
 - faster updates
 - legacy: use omp in ::Update to multithread a function that eats 40% of the time spent in ::Update
   - this gives a _massive_ boost with like >30% more FPS
First you increased the update speed, thereby significantly reducing the Sim FPS. Then you multithreaded a function which made it ~10% faster, but this did not anywhere near restore it to the Sim FPS level you had to begin with. So you made it slower and are still claiming a MASSIVE 30% BOOST.

Faster updates is good in many ways, but take it easy with the propaganda.
0 x

abma
Spring Developer
Posts: 3548
Joined: 01 Jun 2009, 00:08

Re: ATI slow performance in 0.94.x versions

Post by abma » 11 Apr 2013, 18:21

zerver wrote: Faster updates is good in many ways, but take it easy with the propaganda.
i'm really annoyed about the propaganda, too as mostly it is off-topic and it gets off-topic afterwards.

@ismo:

do you have the same settings for spring 94.1?

you can compare infolog.txt from both versions, the first line shows the config file that is used.
0 x

User avatar
jK
Spring Developer
Posts: 2299
Joined: 28 Jun 2007, 07:30

Re: ATI slow performance in 0.94.x versions

Post by jK » 11 Apr 2013, 18:48

zerver wrote:Please stop making Spring slower :mrgreen:
I am not the one who makes it slower! I spend A DAMN LOT TIME running HUNDREDS of benchmarks. And 94 IS FASTER.
When someone makes stuff slower it's you (first in 89 your footprint change) and now you disabled OMP in spring-mt.

The maths is like follows:

+ I made pathfinder like twice as fast with OMP
- many ppl requested a faster responding pathfinder, so I increased update rate by like ~10%
-----------------------------------------------
= time spend in PFS is just ~60-80% compared to 91

So blame yourself to spawn redundant RenderHelperThreads, instead of OMP ones.

PS: Something similar happens in attack range drawing, I doubled the resolution of the circle there when it is compiled with OMP, combined with OMP it eats ~equal time as before and increases the quality w/o any drawbacks. But with your spring-mt (disabled omp!) you just get a noticeable lag.
0 x

ismo
Posts: 33
Joined: 27 Dec 2009, 13:52

Re: ATI slow performance in 0.94.x versions

Post by ismo » 11 Apr 2013, 20:03

Hmm, yeah my setting are the same (I have not added any lines to .ini).

And the springsettings - Render quality / video mode tab having:

Enabled v-sync
24-bit z-buffer

3D trees
High-res clouds
Reflective units
Enable luashaders support
shadows (slow): on
Water quality: reflective+refractive
(all other options disabled from render quality options)

And in render detail tab:
Shadow map 192
tree view distance: at max value
Terrain detail: at max value
Unit LOD distance: at max value

Grass detail: around value 7
Ground decals: between 0 and 1
Max Particles: 20000
MAx nano particles: 20000
0 x

User avatar
jK
Spring Developer
Posts: 2299
Joined: 28 Jun 2007, 07:30

Re: ATI slow performance in 0.94.x versions

Post by jK » 11 Apr 2013, 20:09

Delete your whole configfile, your settings are foobar.
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14585
Joined: 17 Nov 2005, 02:43

Re: ATI slow performance in 0.94.x versions

Post by Forboding Angel » 11 Apr 2013, 22:34

Max particles 20k...

Jesus christ. That will destroy your computer in long games.

Do what JK said.
0 x

zerver
Spring Developer
Posts: 1358
Joined: 16 Dec 2006, 20:59

Re: ATI slow performance in 0.94.x versions

Post by zerver » 12 Apr 2013, 17:54

jK wrote:you disabled OMP in spring-mt
In Spring MT (unofficial) yes. It is currently not needed there because of the separate pathfinder thread.

In Spring (ASIM GML OMP) I will re-enable it if I can make sure OMP and ASIM/GML don't bite each other. Lack of OMP only makes the typical game ~5% slower.
0 x

ismo
Posts: 33
Joined: 27 Dec 2009, 13:52

Re: ATI slow performance in 0.94.x versions

Post by ismo » 12 Apr 2013, 18:31

Well crazy settings or no but those have worked just smoothly for me before 94x versions. But yeah maybe I drop then few particles away :)

I have played long games and 5 vs 5 games etc no problems with those settings before 94x versions, hence I wonder who is foobar - my settings or spring core :)
0 x

zerver
Spring Developer
Posts: 1358
Joined: 16 Dec 2006, 20:59

Re: ATI slow performance in 0.94.x versions

Post by zerver » 12 Apr 2013, 18:58

Test if you get better performance with Spring MT.
http://springrts.com/wiki/Spring_MT

(you can only play it on special servers, or try "spring-mt.exe" in single player mode)
0 x

abma
Spring Developer
Posts: 3548
Joined: 01 Jun 2009, 00:08

Re: ATI slow performance in 0.94.x versions

Post by abma » 12 Apr 2013, 19:32

zerver wrote:Test if you get better performance with Spring MT.
@zerver: http://springrts.com/phpbb/viewtopic.php?f=22&t=30162
0 x

Hermuld
Posts: 20
Joined: 28 Apr 2012, 14:38

Re: ATI slow performance in 0.94.x versions

Post by Hermuld » 19 Apr 2013, 17:31

Spring 94 is unplayable for me. Cpu goes 100% and I'm not playing realtime but falling behind every second. Logflush is set 0.

I tested this and it can't be a pathfinding issue cause it runs ok with hunders of units moving. When the shooting begins it freezes. Again, when there is no shooting it runs ok. Might be some new fancy effects? How to turn them off?

Older versions used to run ok.

I have AMD/ATI/Vista 32.

My settings:
Everything off/minimum expect
max particles 500

I also tested multithread.exe in single player mode but it wasn't any better. I just also got spammd with luarules error.
0 x

User avatar
Jools
XTA Developer
Posts: 2804
Joined: 23 Feb 2009, 16:29

Re: ATI slow performance in 0.94.x versions

Post by Jools » 19 Apr 2013, 18:41

We did some testing with many units to see what causes the lag. It's not just ATI btw. There are two separate issues that are the main cause for lag. They are:

1) Unit collissions and
2) Ground deformations xta problem

All of these were tested with latest xta (9.726) and on different maps. Latest xta still has too big collission volumes, could be partly a cause.

1) unit collissions:
------------------

We tested to make 300 stumpies on a flat and undeformable map. Just moving them forward is no problem. But when you order them to patrol an area so they collide with each other, fps drops from 140 to like 10.

We believe the same happens when in a battle.

2) Ground deformations:
------------------------
Main costly threads are:

Unit::MoveType::Update,
PathManager::TerrainChange and
PathManager::RequestPath

We tested with hundreds of units and on different maps, with map deformation on and off. One single nuke causes a lot of lag when the ground deformation causes the pathfinder to need a lot of updates to path.


Edit:
-----

Tested with luarules and luaui disabled too: the deformation problem is then gone, that's a mod problem it seems. But the collissions are because of engine.
0 x

User avatar
Anarchid
Posts: 1380
Joined: 30 Nov 2008, 04:31

Re: ATI slow performance in 0.94.x versions

Post by Anarchid » 19 Apr 2013, 22:19

Tested with luarules and luaui disabled too: the deformation problem is then gone, that's a mod problem it seems. But the collissions are because of engine.
I believe ZK LuaRules load has climbed significantly as well. Whatever it is, something changed and must be found.
0 x

Post Reply

Return to “Help & Bugs”

cron