Problem with font

Problem with font

Discuss your problems with the latest release of the engine here. Problems with games, maps or other utilities belong in their respective forums.

Moderator: Moderators

Post Reply
Zgudi
Posts: 7
Joined: 10 Nov 2010, 22:52

Problem with font

Post by Zgudi » 10 Nov 2010, 23:18

Hi, this is my first post from a few years absence.

I installed the Spring_0.82.6.1.exe + Ballanced_Annihilation V.19 + some maps. And I have a serious problem with fonts. It does not display correctly.
Please help!

Link to image:
http://img253.imageshack.us/img253/4143/screenwl.jpg
http://img269.imageshack.us/img269/4553/screensu.jpg

Perhaps a similar topic was........
but I could not find
Last edited by Zgudi on 10 Nov 2010, 23:52, edited 2 times in total.
0 x

User avatar
Jazcash
Posts: 5302
Joined: 08 Dec 2007, 17:39

Re: Problem with font

Post by Jazcash » 10 Nov 2010, 23:40

I get this ... on my netbook.
0 x

User avatar
TradeMark
Posts: 4867
Joined: 17 Feb 2006, 15:58

Re: Problem with font

Post by TradeMark » 11 Nov 2010, 01:24

Does it appear on the smallest maps? Like http://springfiles.com/show_file.php?id=716

Looks like youre out of memory, or you dont support some thing, but i bet its memory problem. How old is the laptop?
0 x

Zgudi
Posts: 7
Joined: 10 Nov 2010, 22:52

Re: Problem with font

Post by Zgudi » 11 Nov 2010, 07:52

My Computer:
Windows 7
Mainboard: Gygabyte G31M-ES2L
Ram: 2GB DDR2
Procesor: Intel Dula Core 2,40Ghz
Unfortunately, the graphics card broke
At the moment is integrated, even though I played Star Wars Empires at War (2006) on high settings with no problem, but without schader.

Maybe something graphics card does not support?
Last edited by Zgudi on 11 Nov 2010, 09:01, edited 2 times in total.
0 x

Chojin
Posts: 141
Joined: 04 Oct 2006, 11:22

Re: Problem with font

Post by Chojin » 11 Nov 2010, 08:37

I had this too. It had to do with some older lua script using the fontHandler in a (now) wrong way. Are you using inlinetip-bm by any chance?
0 x

User avatar
manolo_
Posts: 1370
Joined: 01 Jul 2008, 00:08

Re: Problem with font

Post by manolo_ » 11 Nov 2010, 09:47

i had something similiar in the past and it was not hardware related, i had it just with the inline widget, but after bumping at the dev it worked again. i dunno what caused this problem
0 x

Zgudi
Posts: 7
Joined: 10 Nov 2010, 22:52

Re: Problem with font

Post by Zgudi » 11 Nov 2010, 09:48

Quotes from http://springrts.com/phpbb/viewtopic.ph ... &start=560
Tronic wrote:I've been suffering of huge resource leak and Spring crashes (every time after about 25 minutes of small FFA game) and I also saw the font glitch happen. Not sure if this is because of the new IceUI, but here is the log: http://codepad.org/31qynESC

Notice that I was disabling a widget (inlinetip-bm) right when it happened, in IceUI widget dialog (this is where the text displayed wrong for a fraction of a second and then LuaUI crashed).
Chojin wrote:The inlinetip-bm widget seems to use the old fontHandler in a wrong way and caused these graphic glitches for me too.

In my locally modified version I have switched to gl.Text() which has other disadvantages, but no more glitches (as far as I can see):

http://git.develz.org/?p=spring-lua.git ... ua;hb=HEAD
Quote from http://springrts.com/phpbb/viewtopic.ph ... 09#p454309
silver wrote:I have exactly the same problem when I want to install spring 0.82.5 but if you want to play spring you most get spring 0.81.2, I have this version and it works fine
please someone help, why for new version of spring hapen this and in older ones dont?
Inlinetip-bm? I'm new, so I do not know what's going on, but try to learn something.

Hmmmm.. I will try to update the mainboard drivers for Windows 7 Edit: it does not work. Now I installed 0.81.2 Version, and everything works, but the last version 0.82.6.1 does not work.
Can anybody give advice on how to fix this problem with font?
0 x

User avatar
Beherith
Moderator
Posts: 4934
Joined: 26 Oct 2007, 16:21

Re: Problem with font

Post by Beherith » 11 Nov 2010, 17:59

Press f11 ingame, disable all widgets, then relaunch spring, and enable one by one until the problem come back - then you have which widget caused it.
0 x

Zgudi
Posts: 7
Joined: 10 Nov 2010, 22:52

Re: Problem with font

Post by Zgudi » 11 Nov 2010, 18:32

As written, I disabled all widgets (All widgets have red color on the list), after ran again spring (+ restart computer). And the problem with font is still the same.

Screen after restart:
http://img339.imageshack.us/img339/6679/beztytuuoo.jpg

Please help, because now I have a short break, and "I want to annihilate someone terribly" :roll:
0 x

Zgudi
Posts: 7
Joined: 10 Nov 2010, 22:52

Re: Problem with font

Post by Zgudi » 12 Nov 2010, 14:14

I bought a new graphics card and everything to correct itself. I'm so happy :-) :-) :-) :-) :-)
0 x

Post Reply

Return to “Help & Bugs”

cron