Strange crash in spring-dedicated when starting a game

Strange crash in spring-dedicated when starting a game

Discuss your problems with the latest release of the engine here. Problems with games, maps or other utilities belong in their respective forums.

Moderators: Moderators, Moderators

Post Reply
MSSSSM
Posts: 4
Joined: 05 May 2010, 15:35

Strange crash in spring-dedicated when starting a game

Post by MSSSSM »

hi,

I've setup a SPADS autohost and compiled the 0.82.3 spring release.
But when SPADS tries to start a game, this error appears:
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::system::system_error> >'
what(): Address family not supported by protocol
and returncode 6.

I'm sure that SPADS starts the compiled spring and uses libspringserver.so of the compiled spring (I set LD_LIBRARY_PATH)
I've attached the startscript.txt.

There's no firewall on the server.

What could I be doing wrong? Thanks.
Attachments
startscript.txt
(1.06 KiB) Downloaded 27 times
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Re: Strange crash in spring-dedicated when starting a game

Post by hoijui »

Code: Select all

HostIP=localhost;
or it is an IPv6 problem.
also, you should compile a version later then 0.82.3.0 (one containing the fixed spring-dedicated (sync check)).
come back if you need help there.
0 x

User avatar
marciolino
Posts: 268
Joined: 06 Sep 2010, 22:59

Re: Strange crash in spring-dedicated when starting a game

Post by marciolino »

Hi, I am experiencing the same problem on Seven. I've tried many things to solve this problem but I'm still having this crash on launching the test game with spads autohosting.
Always the same runtime error and the same "boost::exception_detail" crash in the log files.

So if I'm not missing anything the problem should be my spring-dedicated version, am I right? And in this case, how can I get the last version of it?
I have tried to find it but with no success.

Thanks for the help!
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Re: Strange crash in spring-dedicated when starting a game

Post by hoijui »

i guess you mean Windows 7.
latest release is here (including spring-dedicated):
http://springrts.com/dl/buildbot/defaul ... /0.82.5.1/
0 x

User avatar
bibim
Lobby Developer
Posts: 912
Joined: 06 Dec 2007, 11:12

Re: Strange crash in spring-dedicated when starting a game

Post by bibim »

Actually, I had noticed some time ago already that on Windows systems with IPv6 enabled, spring-dedicated.exe wasn't able to connect to SPADS and produced this crash. Unfortunately, it seems there is no way to force spring-dedicated to use IPv4 for AutoHost interface when it detects IPv6 is available.
I used to compile a SPADS-specific spring-dedicated.exe with IPv6 disabled for AutoHost interface to fix this problem on Windows systems...
0 x

Post Reply

Return to “Help & Bugs”