Page 1 of 1

SOLVED: 0.82.3 Issues

Posted: 15 Aug 2010, 06:25
by Noobster
Alright, how to begin...

Since downloading spring 0.82.3 I started having troubles launching any mod from any lobby, be it SpringDownloader, TASclient, or SpringLobby.

My first errors ranged from the one shown in the infolog (which seems like a driver issue on the surface), to problems loading unit .jpg files and even issues parsing the [UNITINFO] table. Every stacktrace was different with seemingly random errors.

I had tried uninstalling the .net framework, uninstalling spring (even the mods), and even updating to the 10.7 Catalyst ES 2.0 drivers. None of these solved my issue.

Strangely enough the solution seemed to be deleting my spring directory that is found in "...[username]/documents/my games/spring"

So, if you have started experiencing new errors since updating spring, I would recommend backing up your maps directory, deleting your ".../documents/my games/spring" folder, and reinstalling spring from scratch.

Hopefully this can help someone else solve their issues. Good luck!

Note: I had never experienced any real problems with spring prior to this update

Re: SOLVED: 0.82.3 Issues

Posted: 15 Aug 2010, 12:08
by losbellos
I got solution too, but it was not really the reinstall of spring, since I did that on a new windows. What worked for me is to uninstall all ati drivers and then restart and then install new drivers and then restart again.

So this time I did in two steps usually I do uninstall, install and then restart. THis helped. But it is also true that my spring installation is new.

Re: SOLVED: 0.82.3 Issues

Posted: 17 Aug 2010, 22:58
by Klopper
In Spring settings, do NOT have dynamic clouds and high-res clouds activated AT THE SAME TIME! It will give you the dreaded atioglxx.dll driver crash (at least for me, i have a Radeon 4870 and am using the Catalyst 10.7 Beta OpenGL ES 2.0 drivers which Yuri linked to, they resolved my old driver crash issues). If you have only one of the two settings activated it works fine.

Re: SOLVED: 0.82.3 Issues

Posted: 18 Aug 2010, 00:04
by Klopper
Another strange thing just figured out: If using bump-mapped water, using shorewaves ONLY works on maps with water, but will cause the driver crash for maps WITHOUT water.

Re: SOLVED: 0.82.3 Issues

Posted: 18 Aug 2010, 04:09
by Noobster

Funny you say that. I noticed today I was getting the same crash you had (which is supposed to be related to ATI cards). For me the crash occured after enabling anti-aliasing. So it seems the ATI cards can work with any driver as long as certain settings are disabled.