Intel HD Graphics Driver issue?

Intel HD Graphics Driver issue?

Discuss your problems with the latest release of the engine here. Problems with games, maps or other utilities belong in their respective forums.

Moderator: Moderators

Post Reply
tberthel
Posts: 59
Joined: 12 Jan 2008, 06:17

Intel HD Graphics Driver issue?

Post by tberthel » 21 Jul 2010, 15:22

Seems that I get 120 fps on most maps, but on TheRockFinal it goes to 0-1 fps in darker areas of the map.

I have the latest drivers for the Intel HD Graphics, and I have tried all the settings I could put up with.

Note: I remember the same thing happened on the 945GMA I used to have, but it was fixed with a graphics driver update.

Any ideas other than get ATI or Nvidia?
0 x

slogic
AI Developer
Posts: 626
Joined: 17 Mar 2008, 19:03

Re: Intel HD Graphics Driver issue?

Post by slogic » 21 Jul 2010, 18:19

I have already reported this abnormality here: http://springrts.com/phpbb/viewtopic.php?f=11&t=23081

My last hope is Intel Corporation will fix its driver cause Spring devs won't mess with Intel glitches.

Byt the way, what driver version do you use?
0 x

tberthel
Posts: 59
Joined: 12 Jan 2008, 06:17

Re: Intel HD Graphics Driver issue?

Post by tberthel » 24 Jul 2010, 08:45

15.17.7.2141 (8.15.10.2141)
0 x

tberthel
Posts: 59
Joined: 12 Jan 2008, 06:17

Re: Intel HD Graphics Driver issue?

Post by tberthel » 24 Jul 2010, 08:45

I will talk to Intel.
0 x

tberthel
Posts: 59
Joined: 12 Jan 2008, 06:17

Re: Intel HD Graphics Driver issue?

Post by tberthel » 24 Jul 2010, 09:07

I sent the following to Intel under Intel HD Graphics support:

I notices some rendering problems while playing Spring RTS. This same issue used to occur on my older GMA 945 before Intel was notified of the bug. So, I hope that by providing the same info again again that the bug will be submitted to the development team for the driver so it is fixed like it was for the GMA 945.

The issue is as follows when viewing darker portions of some maps in the Spring RTS game the driver gets very slow in a near recursive loop for that portion of the rendering. Further info to replicate the bug.

1. Download the free game Spring RTS from http://springrts.com/
2. Install the game.
3. Download one of the maps that makes the video driver fail. One such map is called TheFinalRock. You can obtain the map from: http://www.springfiles.com/show_file.php?id=877 Note: The URL may change but the map will always be available.
4. Download the latest BA mod for Spring RTS at: http://www.springfiles.com/show_file.php?id=2528. Note: The error occurs on all mods but BA is the most stable.
5. Run a single player game with the mod and map.
6. Move over a dark area of the map and you will see the frame rate drop a bunch. Usually from about 60 fps to 1 fps. Yet no special processing is required the graphics driver just thinks that more processing is needing in the darker areas of the map. You may follow or report the Intel HD Graphics bug fix at: http://springrts.com/phpbb/viewtopic.php?f=11&t=23541
0 x

tberthel
Posts: 59
Joined: 12 Jan 2008, 06:17

Re: Intel HD Graphics Driver issue?

Post by tberthel » 28 Jul 2010, 00:21

They sent me the following reply:

So far, we do not have any reports from other customers in regards to this, if the game is not on the compatibility list for this graphics controller, this means Intel has not specifically tested the game on this controller, and is not aware of any issues: http://www.intel.com/support/graphics/sb/CS-031017.htm



Please let us know what is your computer manufacturer and model number as well as the operating system and driver version.



We appreciate the your feedback.



Sincerely,



Andrew S.
0 x

tberthel
Posts: 59
Joined: 12 Jan 2008, 06:17

Re: Intel HD Graphics Driver issue?

Post by tberthel » 28 Jul 2010, 00:38

So if your having problems as well please notify Intel.
0 x

tberthel
Posts: 59
Joined: 12 Jan 2008, 06:17

Re: Intel HD Graphics Driver issue?

Post by tberthel » 28 Jul 2010, 00:48

Here is where you can report the bug:

http://supportmail.intel.com/scripts-em ... e.aspx?id=

If enough people that have the issue submit they will fix it.
0 x

slogic
AI Developer
Posts: 626
Joined: 17 Mar 2008, 19:03

Re: Intel HD Graphics Driver issue?

Post by slogic » 28 Jul 2010, 13:52

Interesting, what's their "enough" threshold? :? I'll post eventually too. But i need to update my drivers first which may disable my DVI output again. I'm scared a bit.
0 x

slogic
AI Developer
Posts: 626
Joined: 17 Mar 2008, 19:03

Re: Intel HD Graphics Driver issue?

Post by slogic » 28 Jul 2010, 16:57

Well, just updated. With 6.14.10.5268 (for Windows XP SP3) Spring 0.82 RC is not playable at all. I'm getting a crash with an empty stacktrace. Everything is at lowest settings, shadows are disabled.
Last edited by slogic on 29 Jul 2010, 12:44, edited 2 times in total.
0 x

slogic
AI Developer
Posts: 626
Joined: 17 Mar 2008, 19:03

Re: Intel HD Graphics Driver issue?

Post by slogic » 29 Jul 2010, 12:02

Weee, i turned off texture compression and it worked!

PS. On FolsomDamDeluxeV2 with latest drivers the FPS drop to 1 occurs while zooming out on some threshold value. When zoom is close enough i can play.

PSS. With reflective units turned ON units are not visible and after a while i'm getting a crash. What a crap drivers.
Attachments
infolog.txt
A crash when "Reflective units" turned ON
(15.48 KiB) Downloaded 174 times
Last edited by slogic on 12 Dec 2010, 22:19, edited 1 time in total.
0 x

tberthel
Posts: 59
Joined: 12 Jan 2008, 06:17

Re: Intel HD Graphics Driver issue?

Post by tberthel » 12 Dec 2010, 19:10

The problem has been fixed as of driver version: 8.15.10.2246 for Windows 7.
0 x

abma
Spring Developer
Posts: 3555
Joined: 01 Jun 2009, 00:08

Re: Intel HD Graphics Driver issue?

Post by abma » 12 Dec 2010, 22:58

0 x

slogic
AI Developer
Posts: 626
Joined: 17 Mar 2008, 19:03

Re: Intel HD Graphics Driver issue?

Post by slogic » 13 Dec 2010, 14:28

Gonna check this...

Well, downloaded latest drivers for Windows XP: 6.14.10.5303 (14.42.08.5303). Same shit!
0 x

User avatar
Neddie
Community Lead
Posts: 9406
Joined: 10 Apr 2006, 05:05

Re: Intel HD Graphics Driver issue?

Post by Neddie » 16 Dec 2010, 01:54

Thanks for getting behind this and getting in touch with Intel!
0 x

slogic
AI Developer
Posts: 626
Joined: 17 Mar 2008, 19:03

Re: Intel HD Graphics Driver issue?

Post by slogic » 24 Dec 2010, 13:03

Damn, this bug occurs when rendering Conflict Terra units.
Attachments
step3.jpg
unit is visible, FPS = 1, CPU usage = 100%
(116.15 KiB) Downloaded 5 times
step2.jpg
closer to unit, getting worse FPS, more Draw world & CPU usage
(115.67 KiB) Downloaded 5 times
step1.jpg
here is fine
(114.54 KiB) Downloaded 5 times
0 x

Post Reply

Return to “Help & Bugs”