Crash

Crash

Discuss your problems with the latest release of the engine here. Problems with games, maps or other utilities belong in their respective forums.

Moderator: Moderators

Post Reply
User avatar
Blue_Falcon
Posts: 155
Joined: 16 Oct 2008, 18:54

Crash

Post by Blue_Falcon » 05 Sep 2009, 12:41

Trying to watch a replay.
Map: Nuclear Winter v1
Mod: BA 7.01
Spring version: 0.80.4
Replay version: 0.80.4
System: Ubuntu 9.04 x86_64

Crashes with SIGABRT, attached infolog and replay.

UPDATE: No replays work for me, same crash each time. Single Player with Skirmish AI works, so does multiplayer
Attachments
local_20090904_174453_Nuclear_Winter_v1_0.80.4.sdf
(4.25 MiB) Downloaded 4 times
infolog.txt
(19.03 KiB) Downloaded 16 times
0 x

User avatar
clericvash
Posts: 1394
Joined: 05 Oct 2004, 01:05

Re: Crash

Post by clericvash » 06 Sep 2009, 13:00

I know this is on Linux but since it is a bug it should go in the Bugs forum?
0 x

User avatar
Blue_Falcon
Posts: 155
Joined: 16 Oct 2008, 18:54

Re: Crash

Post by Blue_Falcon » 06 Sep 2009, 18:50

Oops, didn't see a bugs forum. Sorry, please move.
0 x

User avatar
Blue_Falcon
Posts: 155
Joined: 16 Oct 2008, 18:54

Re: Crash

Post by Blue_Falcon » 07 Sep 2009, 19:26

(thanks for moving)

Is there a known fix for this?
Or is the cause unknown?
0 x

User avatar
Blue_Falcon
Posts: 155
Joined: 16 Oct 2008, 18:54

Re: Crash

Post by Blue_Falcon » 16 Sep 2009, 15:43

*bump* Any idea, anyone?
0 x

Auswaschbar
Spring Developer
Posts: 1254
Joined: 24 Jun 2007, 08:34

Re: Crash

Post by Auswaschbar » 16 Sep 2009, 15:48

Did you use springlobby to start the replay? If so, please try without.
0 x

User avatar
Blue_Falcon
Posts: 155
Joined: 16 Oct 2008, 18:54

Re: Crash

Post by Blue_Falcon » 16 Sep 2009, 15:53

Yup, it works from commandline. Thanks for the help!
([tto]gedanken told me first, a couple of seconds ago, but thanks anyway :) )

Which leaves the question, (when?) will the bug be fixed in springlobby?
0 x

Auswaschbar
Spring Developer
Posts: 1254
Joined: 24 Jun 2007, 08:34

Re: Crash

Post by Auswaschbar » 16 Sep 2009, 15:57

Blue_Falcon wrote:Yup, it works from commandline. Thanks for the help!
([tto]gedanken told me first, a couple of seconds ago, but thanks anyway :) )

Which leaves the question, (when?) will the bug be fixed in springlobby?

Code: Select all

system(springexecutable.c_str(), springexecutable.c_str(), demofile.c_str());
Dunno what they manage to get wrong there.
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Re: Crash

Post by hoijui » 16 Sep 2009, 17:44

i have a guess it has to do with the CWD or something (eg springlobbies CWD beeing used, but spring expecting the spring root dir to be it.. or whatever).
0 x

User avatar
Blue_Falcon
Posts: 155
Joined: 16 Oct 2008, 18:54

Re: Crash

Post by Blue_Falcon » 25 Sep 2009, 19:50

CWD? What's that?
And I think the problem lies with the script.txt. I don't see anyhow why one needs to be generated...
0 x

Post Reply

Return to “Help & Bugs”

cron