Graphical issue

Graphical issue

Discuss your problems with the latest release of the engine here. Problems with games, maps or other utilities belong in their respective forums.

Moderator: Moderators

Post Reply
TheMalar
Posts: 4
Joined: 14 Jan 2019, 20:46

Graphical issue

Post by TheMalar » 14 Jan 2019, 20:52

After starting the game everything gets dark in a matter of 2 seconds. I tried to change the graphical options but nothing seems to work. The game looks liek this:

https://i.imgur.com/YJuRrKz.jpg

I could not find a solution online.
1 x

User avatar
PicassoCT
Journeywar Developer & Mapper
Posts: 10082
Joined: 24 Jan 2006, 21:12

Re: Graphical issue

Post by PicassoCT » 14 Jan 2019, 23:41

Does this happen for one particular mod, or one particular map?
Does it happen when all widgets are off?
1 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14486
Joined: 17 Nov 2005, 02:43

Re: Graphical issue

Post by Forboding Angel » 15 Jan 2019, 01:18

Try pressing "L"?
2 x

MasterBel
Posts: 98
Joined: 18 Mar 2018, 07:48

Re: Graphical issue

Post by MasterBel » 15 Jan 2019, 10:53

That's BA's LoS (Line of Sight) mode, which is default. You can disable it by pressing the "L" key. You can change to an alternate mode by toggling the "BA LOS Colours" widget (f11 and scroll. Widgets are sorted alphabetically.)

I advise you join BA's Discord server, and ask for future help there. Hope this helps, have fun! :)

~MasterBel2
2 x

TheMalar
Posts: 4
Joined: 14 Jan 2019, 20:46

Re: Graphical issue

Post by TheMalar » 15 Jan 2019, 18:29

Thanks. The "L" key was the solution. :)

As I don't want to make a new topic could someone also help me with one more thing:

I set my color in the lobby, but in the game my color is always orange and the AI forces are always light blue.

Thanks again.
1 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14486
Joined: 17 Nov 2005, 02:43

Re: Graphical issue

Post by Forboding Angel » 16 Jan 2019, 01:03

That's because picking a color in the lobby is a very old solution that more often than not produces undesireable results, like enemies picking almost exactly the same color as your ally, all enemies picking the exact same color, etc. The autohost tries to mitigate this but tbh it's a bandaid that doesn't stick very well.

So ingame, the enemy and ally colors are automatically chosen using a highly sophisticated selection system which guarantees that enemy and ally colors will always contrast well.

You can disable the advanced color palette and instead use the lobby color palette by toggling it in the options menu. This, however can produce some fairly undesireable results.
2 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14486
Joined: 17 Nov 2005, 02:43

Re: Graphical issue

Post by Forboding Angel » 16 Jan 2019, 01:05

Also, it's worth noting, L aka LOS is super important information. With Los turned off you will not have any exact idea of where your vision ends or begins.
2 x

TheMalar
Posts: 4
Joined: 14 Jan 2019, 20:46

Re: Graphical issue

Post by TheMalar » 16 Jan 2019, 07:12

Got it. Thanks for the info. :) Will keep that in mind.
1 x

Post Reply

Return to “Help & Bugs”

cron