compat mode 104

compat mode 104

Post just about everything that isn't directly related to Spring here!

Moderator: Moderators

Post Reply
Ares
Balanced Annihilation Developer
Posts: 412
Joined: 19 Mar 2011, 13:43

compat mode 104

Post by Ares »

Hi in our 7v7 BA game yesterday we had 4 users on older opengl version machines and 2 people on Macs.

Please release a limited version of 104 that supports old devices because half of our users would be unable to play if we go to 104 otherwise - it's ok if there are less features than the full version, we just want to try the new engine. Thanks
User avatar
AF
AI Developer
Posts: 20686
Joined: 14 Sep 2004, 11:32

Re: compat mode 104

Post by AF »

The very changes that you're asking to be undone/removed are the changes necessary for MacOS support to be possible. Apple removed support for the those older versions of OpenGL, so your request would reduce not improve compatibility for those users.

Even ignoring that, you're asking for several hundred hours of development work to take place. Essentially $30-40k worth of engineering time if this were done commercially. I you can find and persuade someone to do that, and in a way that isn't a hard fork or causes problems, then I salute you.

As a Mac user myself, the new engine in its fullest form is the best chance I have to run Spring natively
MasterBel
Posts: 262
Joined: 18 Mar 2018, 07:48

Re: compat mode 104

Post by MasterBel »

I have a fork of 104 XXXX that seems to run ok on Mac, (it can run BAR even!) only definite issue is that infotextures (LOS view, elevation map, etc) are borked (On Mac). Ivand tested it for me on Windows once and the infotextures worked there so it would probably work on other legacy machines. I haven't been able to identify what the problem is (let alone fix it) due to my highly limited C++/OpenGL/Engine experience. I could have another go at building a transportable package if you'd like.

And No, AF, the new engine won't run on Mac (unless things have changed since I heard last). According to Ivand it will depend significantly upon features from OpenGL 4.3 Core (Macs support Compatability up to 2.1 and Core up to 4.1). I've tried getting the Develop branch running on Mac before and there are significant things that won't work.
Ares
Balanced Annihilation Developer
Posts: 412
Joined: 19 Mar 2011, 13:43

Re: compat mode 104

Post by Ares »

we had an 8v8 with 8 Mac players the other day
Post Reply

Return to “Off Topic Discussion”