Search

Search found 1080 matches

by koshi
06 Jan 2013, 19:58
Forum: Linux
Topic: Ubuntu packages for SpringLobby 0.159
Replies: 7
Views: 1034

Re: Ubuntu packages for SpringLobby >0.157

Packages for 0.159 are now queued for building in my ppa.
by koshi
04 Jan 2013, 16:32
Forum: Linux
Topic: Ubuntu packages for SpringLobby 0.159
Replies: 7
Views: 1034

Ubuntu packages for SpringLobby 0.159

I've got updated debs for 0.157 with pr-downloader integration available at https://launchpad.net/~koshi/+archive/ppa/
I'd like feedback on those before I put them in the mainline spring ppa please.
by koshi
06 Sep 2012, 10:18
Forum: Linux
Topic: Pissed off with springlobby always updated before repository
Replies: 14
Views: 2560

Re: Pissed off with springlobby always updated before reposi

I did build the 91 packages for ubuntu on the day it was released. They've been sitting at https://launchpad.net/~spring/+archive/staging ever since. Feel free to be pissed of at whoever set 91 live on the main server for not coordinating with anyone who could copy those packages over.
by koshi
27 Aug 2012, 12:02
Forum: News
Topic: Spring 90.0! Ladybug!
Replies: 16
Views: 8546

Re: Spring 90.0! Ladybug!

buntu packages are waiting to be built in a new(thanks to tobi) ppa:
https://launchpad.net/~spring/+archive/staging
by koshi
08 Aug 2012, 17:21
Forum: Linux
Topic: Why is there only one version of Spring in the ppa?
Replies: 5
Views: 1100

Re: Why is there only one version of Spring in the ppa?

There's a difference between you being able to force an older version to install and having multiple versions 'visible'. The former you already can, as far back as there had been builds only ofc. The latter isn't possible because spring packages don't carry a version in the package name. So it's alw...
by koshi
29 Jul 2012, 22:10
Forum: Linux
Topic: Oldest compiler?
Replies: 4
Views: 1549

Oldest compiler?

To all packagers: what is the oldest compiler Spring/SpringLobby is currently build with?
One of the next SL releases might need gcc 4.5 minimum and I'd like to know who'd get stuck without updates.
by koshi
25 Jul 2012, 20:56
Forum: Infrastructure Development
Topic: spring replay site
Replies: 179
Views: 29358

Re: spring replay site

parse the command stream to find the last team still alive
by koshi
25 Jul 2012, 15:14
Forum: Lobby Clients & Server
Topic: Enable WebSockets (ws) protocol for lobby API
Replies: 14
Views: 3188

Re: Enable WebSockets (ws) protocol for lobby API

Fuel wrote:what technologies
cleartext protocol over sockets
by koshi
24 Jul 2012, 11:31
Forum: SpringLobby Client
Topic: (springlobby) unable to join game due to 88/89 spring
Replies: 22
Views: 3592

Re: (springlobby) unable to join game due to 88/89 spring

I know it's not super productive, but If I'm not stubborn and demand proper documentation I know we'll never have it. Just add what's in source only atm. Compat flag + extra field for engine version in openbattle sounds reasonable enough, but it needs to be available in precise formulation for every...
by koshi
24 Jul 2012, 09:59
Forum: SpringLobby Client
Topic: (springlobby) unable to join game due to 88/89 spring
Replies: 22
Views: 3592

Re: (springlobby) unable to join game due to 88/89 spring

Google_Frog wrote:Engine testing would be even better with multi engine support. The only thing stopping me from using post_release for all ZK games is the lack of multi engine support by other lobbies.
https://github.com/spring/LobbyProtocol/fork_select enter a draft so we can discuss then.
by koshi
23 Jul 2012, 21:31
Forum: SpringLobby Client
Topic: (springlobby) unable to join game due to 88/89 spring
Replies: 22
Views: 3592

Re: (springlobby) unable to join game due to 88/89 spring

By all means, lets rehash that entire crapfest, as long as it leads to a properly documented, consented upon and implementable mechanism. Just like it did for FORCEJOIN and consorts :)
by koshi
23 Jul 2012, 15:13
Forum: SpringLobby Client
Topic: (springlobby) unable to join game due to 88/89 spring
Replies: 22
Views: 3592

Re: (springlobby) unable to join game due to 88/89 spring

koshi wrote: Fact is also that the lobby protocol has not support for multi-version hosting whatsoever. It was to be drafted, discussed and then agreed upon and implemented, but that never came to pass.
That's no claim of mine.
by koshi
23 Jul 2012, 13:51
Forum: SpringLobby Client
Topic: (springlobby) unable to join game due to 88/89 spring
Replies: 22
Views: 3592

Re: (springlobby) unable to join game due to 88/89 spring

Sure, if you'd get people to test new versions without force. That's really MTR though. Fact is there's a bug with the version checking in SL where not all code paths use the same logic. That'll be fixed. Fact is also that the lobby protocol has not support for multi-version hosting whatsoever. It w...
by koshi
23 Jul 2012, 13:25
Forum: SpringLobby Client
Topic: (springlobby) unable to join game due to 88/89 spring
Replies: 22
Views: 3592

Re: (springlobby) unable to join game due to 88/89 spring

koshi wrote:using versions smaller than the one set globally should always result in errors anyhow, anything else might just as well stop testing/bug reporting/etc altogether
by koshi
20 Jul 2012, 23:57
Forum: Linux
Topic: 0.89 on Linux?
Replies: 8
Views: 1518

Re: 0.89 on Linux?

On "Linux" is way too broad. The answer then must be "once you've compiled it".
by koshi
20 Jul 2012, 23:31
Forum: SpringLobby Client
Topic: (springlobby) unable to join game due to 88/89 spring
Replies: 22
Views: 3592

Re: (springlobby) unable to join game due to 88/89 spring

The bug is in context/forced join not checking server rev compat, not the other way round knorke.
by koshi
20 Jul 2012, 21:26
Forum: News
Topic: Spring 89.0!
Replies: 70
Views: 18843

Re: Spring 89.0!

AF wrote:else I'll have to rebrand Shard as 'AbmaSucks AI' to fix Shards reputation being dragged through the mud.
I hope the irony of the requirements for this potential douchebaggery to come to pass is not lost on you.

Go to advanced search