Search

Search found 907 matches

by bibim
14 Apr 2019, 17:50
Forum: SPADS AutoHost
Topic: SPADS AutoHost
Replies: 49
Views: 62842

Re: SPADS AutoHost

Experimental support for TLS has been added in SPADS 0.12.6 (only in "unstable" release for now).
You can try it by adding "lobbyTls=on" as command line parameter when launching SPADS.
by bibim
10 Apr 2019, 09:37
Forum: Infrastructure Development
Topic: Update of Spring IRC bridge needed
Replies: 1
Views: 90

Update of Spring IRC bridge needed

To whoever is managing the IRC bridge instance running on official Spring server: The IRC bridge instance currently running on official Spring server is quite broken due to recent lobby protocol evolutions. The IRC bridge code has been updated 2 weeks ago has detailed here : use new lobby compat fla...
by bibim
11 Mar 2019, 09:33
Forum: Lobby Clients & Server
Topic: messages from spads hosts not appearing on lobby chat
Replies: 8
Views: 656

Re: messages from spads hosts not appearing on lobby chat

Apparently you just replaced a code comment with a new call to "onLobbyConnected()", which should make things worse...
You should revert this commit and just add the "if(getLobbyState() > 3)" check at the end of the line containing the call to "onLobbyConnected()" as I explained.
by bibim
26 Feb 2019, 09:48
Forum: Lobby Clients & Server
Topic: messages from spads hosts not appearing on lobby chat
Replies: 8
Views: 656

Re: messages from spads hosts not appearing on lobby chat

Nothing has changed at SPADS side, the warnings you see in your logs are just due to the "PlayerAnnounce" plugin you are using. It seems this plugin is redefining/erasing callbacks it has already declared. If this is the code you are using for this plugin, then you should just add the check "if(getL...
by bibim
18 Feb 2019, 22:44
Forum: Lobby Clients & Server
Topic: 'u' flag and bridge bot interface -- protocol info
Replies: 6
Views: 519

Re: 'u' flag and bridge bot interface -- protocol info

and note that usernames are case sensitive! Yes that's what I tried initially, but then here is what happened: FAILED msg=Invalid syntax: Only lower case ASCII chars, [], _, 0-9 and . are allowed in location names. cmd=BRIDGECLIENTFROM Also, is there any reason to prevent bridging by the host in pr...
by bibim
18 Feb 2019, 20:44
Forum: SPADS AutoHost
Topic: ~ on usernames makes users unbannable
Replies: 2
Views: 225

Re: ~ on usernames makes users unbannable

It's not SPADS which is doing that but Spring server (cf this).
by bibim
18 Feb 2019, 15:41
Forum: Lobby Clients & Server
Topic: 'u' flag and bridge bot interface -- protocol info
Replies: 6
Views: 519

Re: 'u' flag and bridge bot interface -- protocol info

From a autohost named "Spads": 20190218153434 - DEBUG - [SpringLobbyInterface] Sending to lobby server: "BRIDGECLIENTFROM spads testId testName" 20190218153434 - DEBUG - [SpringLobbyInterface] Received from lobby server: "FAILED msg=You cannot bridge a location named after another bot user cmd=BRIDG...
by bibim
18 Feb 2019, 09:18
Forum: Lobby Clients & Server
Topic: 'u' flag and bridge bot interface -- protocol info
Replies: 6
Views: 519

Re: 'u' flag and bridge bot interface -- protocol info

Silentwings wrote:
08 Feb 2019, 13:09
Bridge bots using the interface must send the flag, and also require a botflag.
So this means autohosts without bot flag can't use the bridge interface for in-game players ?
by bibim
10 Feb 2019, 18:04
Forum: SPADS AutoHost
Topic: spads hosts failed to upload demo files on the last few days
Replies: 6
Views: 346

Re: spads hosts failed to upload demo files on the last few days

No, not necessarily. Especially since accounts dedicated to replay uploading might be automatically deleted if they aren't actually used to login in lobby server (cf this).
by bibim
10 Feb 2019, 10:59
Forum: SPADS AutoHost
Topic: spads hosts failed to upload demo files on the last few days
Replies: 6
Views: 346

Re: spads hosts failed to upload demo files on the last few days

Which account do you use to upload replays, the autohost's one or an account dedicated to replay uploading ?
by bibim
07 Feb 2019, 21:18
Forum: SPADS AutoHost
Topic: Cloudhost SPADS confs
Replies: 1
Views: 227

Re: Cloudhost SPADS confs

I will try to write a longer tutorial on how to set up a spads (its very easy once you figure few things out) later on. Im posting here some of my confs so others dont have to struggle as much as i had to to make !nbteams work Thanks ! These configs are broken in many ways but work for !ffa command...
by bibim
07 Feb 2019, 20:48
Forum: SPADS AutoHost
Topic: SPADS AutoHost
Replies: 49
Views: 62842

Re: SPADS AutoHost

Here are two diagrams to help autohost administrators understand how SPADS settings and presets are organized in the 3 main configuration files: spads.conf, hostingPresets.conf and battlePresets.conf. It is important to understand these 3 files contain different settings, you can't move settings fro...
by bibim
04 Feb 2019, 09:20
Forum: SPADS AutoHost
Topic: TrueSkill 2 vs WHR
Replies: 16
Views: 915

Re: TrueSkill 2 vs WHR

Hmm.. that got me a bit confused since you mentioned "it can't be a bad thing to add support for new skill estimations algorithms in SPADS". Now, if I got that right a SPADS plugin wouldn't be enough, a patch in SLDB to optionally (set per mod) use a TrueSkill2 python module would be required? :?: ...
by bibim
01 Feb 2019, 16:53
Forum: SPADS AutoHost
Topic: TrueSkill 2 vs WHR
Replies: 16
Views: 915

Re: TrueSkill 2 vs WHR

Hey guys, I'm considering the development of a new plugin for SPADS replacing the (now obsolete) TrueSkill by the new TrueSkill 2 calculation. Given it's an official MS thing, I just thought that maybe it should be an update (or option?) to SPADS itself, instead of a plugin. What do you think? I th...
by bibim
08 Jan 2019, 18:48
Forum: Lobby Clients & Server
Topic: How to make SPADS use SLDB for Trueskill
Replies: 0
Views: 135

Re: How to make SPADS use SLDB for Trueskill

There is a SPADS subforum where you can find this information, here for example.
by bibim
08 Jan 2019, 07:39
Forum: Lobby Clients & Server
Topic: TS seems broken
Replies: 14
Views: 845

Re: TS seems broken

Oups, forgot to initialize partitions for the new year...
Should be fixed now (data were still collected and have just been processed retroactively so not a big deal...).
by bibim
05 Jan 2019, 11:24
Forum: SPADS AutoHost
Topic: Autohosts stuck in update loop
Replies: 2
Views: 216

Re: Autohosts stuck in update loop

It seems you have 3 different problems in your autohosts configuration: You have the same logDir absolute path configured for all your autohost instances, which means all these instances will write in the same log files. All your autohost instances have the autoUpdateRelease setting defined, and eve...
by bibim
15 Dec 2018, 23:15
Forum: SPADS AutoHost
Topic: automatic !stats into battleroom at end of game?
Replies: 3
Views: 333

Re: automatic !stats into battleroom at end of game?

The hStats subroutine doesn't use answer() because it would be too easy to flood the battleroom with a few !stats commands (so that the antiflood protection wouldn't be effective). Basically only commands which generate small output use answer(). The easiest way to do what you want is indeed to crea...
by bibim
11 Nov 2018, 10:32
Forum: Lobby Clients & Server
Topic: TS seems broken
Replies: 14
Views: 845

Re: TS seems broken

Data shown on the replay site aren't consistent with what is stored in SLDB (wrong winning team etc.), maybe there is a connection problem between the two ? Concerning recalculation of TS data, the duration varies a lot because SLDB will only recompute necessary data. It usually takes a few minutes ...
by bibim
14 Sep 2018, 16:35
Forum: General Discussion
Topic: rank conditions
Replies: 10
Views: 1168

Re: rank conditions

In case it might be useful to adjust rank conditions:
Image
Spring_ranks.png
(45.11 KiB) Not downloaded yet

Go to advanced search