2019-11-15 01:42 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0006301Spring engineGeneralpublic2019-09-08 19:23
ReporterGoogle_Frog 
Assigned Tohokomoko 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionwon't fix 
Product Version104.0 +git 
Target VersionFixed in Version 
Summary0006301: 104.0.1-1389-g9de23cd maintenance Missing dll error
DescriptionLubster#1739 (on Discord) consistently has an error message that says api-ms-win-crt-heap-l1-1-0.dll is missing whenever they start 104.0.1-1389-g9de23cd. 104.0.1-1383-ga0129db is the last working version with a build. 104.0.1-1395-g6430e47 does not work either. No infolog is generated for the builds that show the error message.
TagsNo tags attached.
Checked infolog.txt for ErrorsIrrelevant
Attached Files

-Relationships
duplicate of 0006299resolvedhokomoko win64 builds still broken 
+Relationships

-Notes

~0020115

hokomoko (developer)

https://answers.microsoft.com/en-us/insider/forum/all/api-ms-win-crt-heap-l1-1-0dll-is-missing/02b7b084-b6fd-44ea-bec7-f3297a11ec6c

~0020116

Google_Frog (reporter)

He tried reinstalling VC++ first. I forgot to mention that the issue was reproduced with the win32 minimal portable builds from the buildbot. https://springrts.com/dl/buildbot/default/maintenance/

~0020117

hokomoko (developer)

No idea then.
Reproduced by you or on his machine?

~0020118

Google_Frog (reporter)

On his machine.

~0020119

hokomoko (developer)

So this doesn't seem to be a spring issue.
I recommend using http://www.dependencywalker.com/
to see which dll looks for api-ms-win-crt-heap-l1-1-0.dll
it will probably be something installed by a third application.

~0020123

Google_Frog (reporter)

I've passed that on.

~0020124

abma (administrator)

next time please check for existing bug reports

~0020127

abma (administrator)

-> please retest with win32 104.0.1-1397-g621da58 maintenance which is fixed

win64 is still broken

see 0006299 for updates

~0020130

abma (administrator)

fyi:

https://buildbot.springrts.com/builders/full-windows-test/builds/7313/steps/test/logs/stdio

[...]
15: err:module:import_dll Library MSVCP140.dll (which is needed by L"Z:\\home\\buildbot\\mingwlibs\\dll\\DevIL.dll") not found
15: err:module:import_dll Library VCRUNTIME140.dll (which is needed by L"Z:\\home\\buildbot\\mingwlibs\\dll\\DevIL.dll") not found
15: err:module:import_dll Library api-ms-win-crt-heap-l1-1-0.dll (which is needed by L"Z:\\home\\buildbot\\mingwlibs\\dll\\DevIL.dll") not found
15: err:module:import_dll Library api-ms-win-crt-string-l1-1-0.dll (which is needed by L"Z:\\home\\buildbot\\mingwlibs\\dll\\DevIL.dll") not found
15: err:module:import_dll Library api-ms-win-crt-stdio-l1-1-0.dll (which is needed by L"Z:\\home\\buildbot\\mingwlibs\\dll\\DevIL.dll") not found
15: err:module:import_dll Library api-ms-win-crt-convert-l1-1-0.dll (which is needed by L"Z:\\home\\buildbot\\mingwlibs\\dll\\DevIL.dll") not found
15: err:module:import_dll Library api-ms-win-crt-math-l1-1-0.dll (which is needed by L"Z:\\home\\buildbot\\mingwlibs\\dll\\DevIL.dll") not found
15: err:module:import_dll Library api-ms-win-crt-time-l1-1-0.dll (which is needed by L"Z:\\home\\buildbot\\mingwlibs\\dll\\DevIL.dll") not found
15: err:module:import_dll Library api-ms-win-crt-runtime-l1-1-0.dll (which is needed by L"Z:\\home\\buildbot\\mingwlibs\\dll\\DevIL.dll") not found
15: err:module:import_dll Library api-ms-win-crt-filesystem-l1-1-0.dll (which is needed by L"Z:\\home\\buildbot\\mingwlibs\\dll\\DevIL.dll") not found
15: err:module:import_dll Library api-ms-win-crt-environment-l1-1-0.dll (which is needed by L"Z:\\home\\buildbot\\mingwlibs\\dll\\DevIL.dll") not found
15: err:module:import_dll Library api-ms-win-crt-utility-l1-1-0.dll (which is needed by L"Z:\\home\\buildbot\\mingwlibs\\dll\\DevIL.dll") not found
15: err:module:import_dll Library DevIL.dll (which is needed by L"Z:\\home\\buildbot\\full-windows-test\\develop\\build\\default\\spring-headless.exe") not found
[...]

+ sorry, i didn't expect that fixing takes this long. i can't say which exact versions are broken

it started with this commit: https://github.com/spring/mingwlibs/commit/499278d36790dc5b6f0a4929d6cbf445d8b9a465
+Notes

-Issue History
Date Modified Username Field Change
2019-09-08 12:36 Google_Frog New Issue
2019-09-08 13:47 hokomoko Note Added: 0020115
2019-09-08 13:47 hokomoko Status new => feedback
2019-09-08 14:27 Google_Frog Note Added: 0020116
2019-09-08 14:27 Google_Frog Status feedback => new
2019-09-08 14:31 hokomoko Note Added: 0020117
2019-09-08 14:33 Google_Frog Note Added: 0020118
2019-09-08 14:53 hokomoko Note Added: 0020119
2019-09-08 14:53 hokomoko Assigned To => hokomoko
2019-09-08 14:53 hokomoko Status new => closed
2019-09-08 14:53 hokomoko Resolution open => won't fix
2019-09-08 15:08 hokomoko Status closed => assigned
2019-09-08 16:40 Google_Frog Note Added: 0020123
2019-09-08 18:46 abma Relationship added duplicate of 0006299
2019-09-08 18:48 abma Status assigned => closed
2019-09-08 18:48 abma Note Added: 0020124
2019-09-08 18:52 abma Note Added: 0020127
2019-09-08 19:23 abma Note Added: 0020130
+Issue History