2019-11-20 07:33 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005818Spring engineGfx driver issuespublic2019-10-01 14:44
Reportergajop 
Assigned Tohokomoko 
PrioritynormalSeveritycrashReproducibilityalways
StatusfeedbackResolutionopen 
Product Version104.0 
Target VersionFixed in Version 
Summary0005818: SpringBoard crashes when trying to export map textures (windows)
DescriptionHere is the issue with more information: https://github.com/Spring-SpringBoard/SpringBoard-Core/issues/284
SpringBoard crashes each time when I try to export engine maps on Windows.

Relevant code where it happens is below:
https://github.com/Spring-SpringBoard/SpringBoard-Core/blob/master/scen_edit/command/export_maps_command.lua#L117-L130

It ends up creating a 0 byte heightmap.png file, but doesn't create a grass file (crashing before that).
The machine where this happens has shaders working normally so I'm not sure what the real reason behind the crash is.

Any info I can provide that can help investigate the issue further?
Steps To Reproduce1. Get SpringBoard for Windows: https://drive.google.com/file/d/0B9FQjbVMFgL2WUYtVUJIRXpkY3M/view?usp=sharing or https://drive.google.com/file/d/0B9FQjbVMFgL2QzVkcWZYNHBBMzQ/view?usp=sharing and launch SpringBoard
2. Save SpringBoard project with Ctrl-S and export maps by pressing Ctrl-E, selecting "Map Textures" as the File Type, writing some filename (e.g. "test") and pressing OK.
3. Observe crash.
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
+Relationships

-Notes

~0018548

Kloot (developer)

ntdll.dll 0x00026DC9 ?? 0
ntdll.dll 0x00040045 ?? 0
ntdll.dll 0x0003FF65 ?? 0
MSVCR80.dll 0x0000E550 ?? 0
SpringBoard-win\data\engine\104.0\DevIL.dll 0x000571C8 ?? 0
SpringBoard-win\data\engine\104.0\spring.exe 0x005B04AF rts/Lua/LuaOpenGL.cpp 4209
SpringBoard-win\data\engine\104.0\spring.exe 0x0096DA40 rts/lib/lua/src/ldo.cpp 321
SpringBoard-win\data\engine\104.0\spring.exe 0x0096DCBF rts/lib/lua/src/ldo.cpp 377

libIL issue with saving float images, not very promising.

~0018551

hokomoko (developer)

There's a new version of libIL, I'll try to see if updating can help.

~0018552

gajop (developer)

It might also be an issue with format = GL_LUMINANCE32F_ARB, or there could be some other workaround.

@hokomoko Let me know if I can assist in any way.

~0018658

The_Yak (reporter)

Can reproduce this consistently on win10. Infolog: https://pastebin.com/vWLvx6p9

~0018659

gajop (developer)

My current "solution" is to export them as 8bit. This is obviously a bit lowres for heightmaps, and not a final solution.

~0020166

hokomoko (developer)

libIL was updated.
Could you please check both win32 and win64 maintenance builds?
https://springrts.com/dl/buildbot/default/maintenance/104.0.1-1411-g72ca6b9/
+Notes

-Issue History
Date Modified Username Field Change
2017-10-23 04:35 gajop New Issue
2017-10-23 04:36 gajop Steps to Reproduce Updated View Revisions
2017-10-23 12:58 Kloot Note Added: 0018548
2017-10-23 16:25 hokomoko Note Added: 0018551
2017-10-24 04:04 gajop Note Added: 0018552
2017-11-22 20:51 The_Yak Note Added: 0018658
2017-11-23 09:00 gajop Note Added: 0018659
2019-10-01 14:44 hokomoko Assigned To => hokomoko
2019-10-01 14:44 hokomoko Status new => feedback
2019-10-01 14:44 hokomoko Note Added: 0020166
+Issue History