2020-08-09 18:26 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003355Spring engineGeneralpublic2012-12-29 01:35
ReporterBeherith 
Assigned ToKloot 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version91.0.1+git 
Target VersionFixed in Version91.0.1+git 
Summary0003355: [91.0.1-566] Many units trying to move to one spot cause high cpu load
DescriptionWhen a large group of land units (100+) are told to move to the same spot, they will clump up and fail to reach destination because of each other. Then they start bouncing on each other. This bouncing causes massive cpu load. BTW pathing is insanely good for large groups, its just this minor niggle.
Steps To ReproduceBA 7.72, /give 200 armpw; move order somewhere close for all of them.

TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
related to 0002994resolvedKloot strange unit bumping when multiple units move to a single point 
has duplicate 0003202resolvedabma Rapid unit bumping when moving to a point can still happen. 
+Relationships

-Notes

~0009514

jK (developer)

DEBUG2 build?
In RELEASE build it should take <15% with 300 pws

~0009515

Beherith (reporter)

I got the build from buildbot, not my own compilation.

~0009524

zerver (reporter)

Side note: Although the high CPU load indeed is a bug, because of multithreaded collision handling and pathfinding, the MTsim branch is super fast for situations like this.
+Notes

-Issue History
Date Modified Username Field Change
2012-12-04 15:11 Beherith New Issue
2012-12-04 15:11 Beherith File Added: screen00216.jpg
2012-12-04 16:29 abma Relationship added related to 0002994
2012-12-04 16:29 abma Relationship added related to 0003202
2012-12-04 18:59 abma Relationship replaced has duplicate 0003202
2012-12-05 17:35 abma Product Version 91.0 => 91.0.1+git
2012-12-05 17:35 abma Target Version => 92.0
2012-12-13 07:46 jK Note Added: 0009514
2012-12-13 07:46 jK Status new => feedback
2012-12-13 08:19 Beherith Note Added: 0009515
2012-12-13 08:19 Beherith Status feedback => new
2012-12-18 17:43 zerver Note Added: 0009524
2012-12-19 02:47 jK Target Version 92.0 =>
2012-12-24 13:55 Changeset attached => spring develop a2b41209
2012-12-24 13:55 Anonymous Status new => resolved
2012-12-24 13:55 Anonymous Resolution open => fixed
2012-12-24 22:00 Changeset attached => spring develop bfc21aad
2012-12-29 01:34 zerver Assigned To => zerver
2012-12-29 01:34 zerver Status resolved => feedback
2012-12-29 01:34 zerver Resolution fixed => reopened
2012-12-29 01:34 zerver Assigned To zerver => Kloot
2012-12-29 01:34 zerver Status feedback => assigned
2012-12-29 01:35 zerver Status assigned => resolved
2012-12-29 01:35 zerver Fixed in Version => 91.0.1+git
2012-12-29 01:35 zerver Resolution reopened => fixed
+Issue History